Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Yarn components are not Hadoop 3.0.3 cluster setup


I have setup Hadoop(3.0.3) cluster Pseudo distributed mode,

when I ran it is starting namenode,datanodes,secondary namenodes but when I ran it is showing warnings.The below one is the screenshot



Master Mentor


Can you please check if all the environment variables are setup properly?

One best way to quickly find out if anything is goig wrong or not is to run the Shell Script "" in DEBUG mode using "sh -x" option as following:   This will give us better ideal if it is failing somewhere :

Example: Running script in DEBUG mode


# sh -x ./ 



Can you please share the whole output fo the above command? 
Also do you see any log is generated for the failure? Like any out/log file if yes then can you please share those logs as well?


@jsensharma  sir,

I ran the command you mentioned it is giving below error

sh: 0: Can't open ./

below is the screenshot

Screenshot from 2019-08-19 16-05-10.png

Master Mentor


As you are getting this error:

sh: 0: Can't open ./


Hence you should check couple of things:


1. Is this file existing in the current directory?

# cd /PATH/TO
# ls -lart  /PATH/TO/

2. What is the permission on the file? Can the current user read/execute it?

# chmod  a+x  /PATH/TO/

# which sh
# sh -x /PATH/TO/


Please replace the '/PATH/TO" with the actual path of the mentioned script.