Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Zeppelin + Livy stoped to run queries: Unable to obtain password from user

avatar
Contributor

Hi, few hours ago zeppelin stopped to run queries and begins to throw errors like 

WARN org.apache.zeppelin.socket.NotebookServer: Job 20230217-161657_1725299508 is finished, status: ERROR, exception: null, result: %text javax.security.auth.login.LoginException: Unable to obtain password from user

Its kerberized AD KDC cluster.

ldapsearch and kinit with right principal works fine.

/etc/hosts are fine too.

The rest services on the cluster are green.

http://hostname:port/api/credential/ returns 

{"status":"OK","body":{"userCredentials":{}}}

What else can I check?

1 ACCEPTED SOLUTION

avatar
Contributor

We've deleted credentials from AD and regenerated it, now zeppelin runs fine.

View solution in original post

1 REPLY 1

avatar
Contributor

We've deleted credentials from AD and regenerated it, now zeppelin runs fine.