Support Questions

Find answers, ask questions, and share your expertise

Zeppelin UI Welcome page is blank

Rising Star

screen-shot-2017-02-15-at-23048-pm.pngWhile opening Zeppelin UI on HD2.5 (on AWS) i don't see any welcome page. When i create a new notebook nothing happens. Also search box "Search your notebook" is also disabled.

zeppelin.anonymous.allowed is set to true. There is no Error/Exception in logs.

8 REPLIES 8

@Ajay

Can you please make sure that the [main] section in shiro.ini file of zeppelin has following properties configured?

sessionManager = org.apache.shiro.web.session.mgt.DefaultWebSessionManager

securityManager.sessionManager = $sessionManager

securityManager.sessionManager.globalSessionTimeout = 86400000

shiro.loginUrl = /api/login

If not, please configure it and restart the zeppelin service.

Rising Star

@Kshitij Badani These two properties were commented. I made the changes and restarted zeppelin but outcome is same.

Explorer
sessionManager = org.apache.shiro.web.session.mgt.DefaultWebSessionManager
securityManager.sessionManager = $sessionManager
securityManager.sessionManager.globalSessionTimeout = 86400000

Please uncomment these lines in shiro.ini file and restart zeppelin.

Rising Star

This issue was caused by port forwarding. Websocket used in Zeppelin UI was not able to communicate with backend.

Contributor

@Ajay

I have the similar issue. whats the change that you made to made it work.

Contributor

@Tech Gig and @Kshitij Badani

Any solution for the problem?

New Contributor

77382-2018-05-24.png

Hi all, I have HDP 2.5 and add zeppeling service, but not show notebooks page, how can i do it?

Solved: only login: admin admin

Explorer

I had the same problem happen more than once on different clusters from different sites and networks configurations (with or without proxy/gateway/knox, company network, wifi router, home ISP, public wifi...). With various results

It concerned the display of the notes themselves and the welcome page also (sometimes only the notes, the welcome page was ok)

Some browser settings block websockets for security reasons. So be aware of that.

Sometimes, it can be a firewall issue.

Last occurence happened to require a clearing of the outputs of the notes. I was working on a note including a spark job that took ages and the progress bar froze. I restarted zeppelin, Spark, Yarn, nothing seemed to fix it. The note seemed "lost", undisplayable, desperately blank. My fix (after a couple of hours trying to figure what the hell was causing that) was to Hover over the note in the welcome page, and click the rubber, "clear output"... and voila,I was able to open my note again. Note That this has to be done after a restart of the Zeppelin service.

Just for note (no pun intented) when I explored the browser prior the fix the websocket kept trying to load content from the server but nothing came out.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.