Support Questions
Find answers, ask questions, and share your expertise

Zeppelin installation fails on HDP 2.4

Explorer

I'm trying to install Zeppelin using this tutorial: http://hortonworks.com/hadoop-tutorial/apache-zeppelin-hdp-2-4/

I have a brand new 2-node HDP cluster with HDP 2.4. I tried to install Zeppelin both at Name Node and the other node. I receive the following stderr in both cases:

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/master.py", line 235, in <module>
    Master().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/master.py", line 85, in install
    user=params.zeppelin_user)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run
    tries=self.resource.tries, try_sleep=self.resource.try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
    raise Fail(err_msg) 

resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/setup_snapshot.sh /usr/hdp/current/zeppelin-server/lib m348hdp2-dev.nova.otp.int 9083 10001 m348hdp2-dev.nova.otp.int 9995 True /var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package /usr/jdk64/jdk1.8.0_60 >> /var/log/zeppelin/zeppelin-setup.log' returned 126. -bash: /var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/setup_snapshot.sh: /bin/bash^M: bad interpreter: No such file or directory

1 ACCEPTED SOLUTION

Accepted Solutions

1. Please check if the file exist?

/bin/bash

2. Try to open your file "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/setup_snapshot.sh" with "vi" editor then set unix with the following commands. See: https://unnisworld.wordpress.com/2006/11/06/how-to-remove-m-from-unix-files-using-vi-editor/

:set ff=unix
:wq

View solution in original post

2 REPLIES 2

1. Please check if the file exist?

/bin/bash

2. Try to open your file "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/ZEPPELIN/package/scripts/setup_snapshot.sh" with "vi" editor then set unix with the following commands. See: https://unnisworld.wordpress.com/2006/11/06/how-to-remove-m-from-unix-files-using-vi-editor/

:set ff=unix
:wq

View solution in original post

Explorer

Wow, that helped! @jk, thank you very much! I understood why I got this message: it's because I git cloned repo from my windows machine and copied the files to linux cluster.