Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-12-2022 08:08 PM
in zeppelin i run show databases; and show tables works but when pyspark to select * from tables
get error permission denied user = anonymous
java.security.AccessControlException: Permission denied: user=anonymous, access=READ, inode="/warehouse/tablespace/managed/hive
when i check getfacl in /warehouse/tablespace/managed/hive user zeppelin can rwx the directory
why does zeppelin read as user anonymous ? anybody can help ? thanks
Created 12-12-2022 10:10 PM
its admin:admin but its solve by add user=hive in
spark.sql.hive.hiveserver2.jdbc.url = jdbc:hive2://ipserver:2181,ipserver:2181,ipserver:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2;user=hive
Created 12-12-2022 08:14 PM
Hello @myzard
Can you confirm with which user you logged in into zeppelin UI
Created 12-12-2022 10:10 PM
its admin:admin but its solve by add user=hive in
spark.sql.hive.hiveserver2.jdbc.url = jdbc:hive2://ipserver:2181,ipserver:2181,ipserver:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2;user=hive
Created 12-12-2022 10:10 PM
this setting in spark interpreter zeppelin