Support Questions
Find answers, ask questions, and share your expertise

ambari-agent failed to start on all nodes

Highlighted

ambari-agent failed to start on all nodes

Contributor

kindly find the attached file ambari-agent-log.txt fo log details of ambari-agent.

ambari-agent not started on all nodes with below message.

Verifying ambari-agent process status... ERROR: ambari-agent start failed. For more details, see /var/log/ambari-agent/ambari-agent.out: ==================== 2017-08-24 10:09:11,210 - call[['test', '-w', '/']] {'sudo': True, 'timeout': 5} 2017-08-24 10:09:11,215 - call returned (0, '') 2017-08-24 10:09:11,215 - call[['test', '-w', '/sys/fs/cgroup']] {'sudo': True, 'timeout': 5} 2017-08-24 10:09:11,219 - call returned (0, '') 2017-08-24 10:09:11,219 - call[['test', '-w', '/run/lock']] {'sudo': True, 'timeout': 5} 2017-08-24 10:09:11,224 - call returned (0, '') 2017-08-24 10:09:11,224 - call[['test', '-w', '/run/shm']] {'sudo': True, 'timeout': 5} 2017-08-24 10:09:11,228 - call returned (0, '') 2017-08-24 10:09:11,228 - call[['test', '-w', '/run/user']] {'sudo': True, 'timeout': 5} 2017-08-24 10:09:11,232 - call returned (0, '')

kindly look into this if possible.

@Jay SenSharma\

Thanks in advance..

3 REPLIES 3
Highlighted

Re: ambari-agent failed to start on all nodes

Super Mentor

@hardik desai

From your ambari agent log i see the following:

ERROR 2017-08-24 09:57:48,188 Controller.py:180 - Cannot register host with non compatible agent version, hostname=slave0.xxxxx.com, agentVersion=2.4.1.0, serverVersion=2.2.1.1

.

So please check the ambari agent version is 2.4.1.0 Where as ambari server version 2.2.1.1

Looks like a RPM mismatch here.

Please check the "/etc/yum.repos.d/amabri.repo" file on all hosts and make sure that it has the correct version.

# cat /etc/yum.repos.d/ambari.repo            (from ambari server and agent machines)

# rpm -qa | grep ambari                 (Run this command on ambari server and agent machines)

.

Please make sure that ambari server and agent are on the same version.

Highlighted

Re: ambari-agent failed to start on all nodes

Contributor

@Jay SenSharma, thanks for prompt reply. i have checked this error & this is what i found.

deb http://10.140.179.252/AMBARI/ubuntu14/2.2.1.1-70/ Ambari main ( ambari server )

deb http://10.140.179.252/AMBARI-2.4.1.0/ubuntu14/2.4.1.0-22/ Ambari main (ambari agent)

Highlighted

Re: ambari-agent failed to start on all nodes

Super Mentor

@hardik desai

You will either need to install ambari agent of the same version as ambari (2.2.1.1-70)

OR

You will have to upgrade your ambari server to "2.4.1.0-22", https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-upgrade/content/upgrade_ambari.ht...

.

Ambari Server and Agent can not be of different versions.

Don't have an account?