Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

apache nifi error with mongodb when upgrading to nifi 1.22

avatar
New Contributor

I tell you that we have updated Apache Nifi from version 1.16 to version 1.22 and we are currently having a problem connecting to the Mongo DB because the server version is very low.

Is there an option that does not involve having to update the database server to be able to leave this connection functional?

Coordinador_1-1701147006980.png

 

 

5 REPLIES 5

avatar
Community Manager

Hi @Coordinador, Welcome to our community! To help you get the best possible answer, I have tagged our NiFi experts @MattWho @TimothySpann @ckumar  @cotopaul @SAMSAL  who may be able to assist you further.

Please feel free to provide any additional information or details about your query, and we hope that you will find a satisfactory solution to your question.



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Master Guru

You may need to update the JDK you are running NiFi with.  What version are you using?  What operating System?   Where did you download NiFi?  Move to NiFi 1.23.2, 1.24 or Cloudera's 1.23.1 version.   Bare metal?   VMs?   Docker?   K8?  Cloud?

 

avatar
New Contributor

- migrate nifi version 1.16 to 1.22

- S.O ubuntu 7.5

- Nifi download, of apache nifi official site

- VM machines

- No docker

The version of mongo driver actually in nifi is major than mongo database 

avatar
Super Mentor

@Coordinador 

You could upgrade your MongoDB to a newer version.

Another option you may try is to add the Apache NiFi 1.16 *mongo* nars to your Apache NiFi 1.22 custom extension folder:
https://nifi.apache.org/docs/nifi-docs/html/administration-guide.html#autoloading-processors

This will make both the 1.16 and 1.22 versions of the mongo processor available for use in your 1.22 Apache NiFi.

The Mongo Driver has been updated numerous times between 1.16 and 1.23:
https://issues.apache.org/jira/browse/NIFI-9886
https://issues.apache.org/jira/browse/NIFI-10557
https://issues.apache.org/jira/browse/NIFI-11419
https://issues.apache.org/jira/browse/NIFI-11856

If you found any of the suggestions/solutions provided helped you with your issue, please take a moment to login and click "Accept as Solution" on one or more of them that helped.

Thank you,
Matt

avatar
Community Manager

@Coordinador,  have any of the replies helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. 



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: