Support Questions

Find answers, ask questions, and share your expertise

can't connect to HDP Sandbox 2.6 on VM with SQuirrel


Here is the stack trace:

java.lang.ClassNotFoundException: org.apache.zookeeper.KeeperException
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.apache.hadoop.hbase.client.ConnectionFactory.createConnection(
at org.apache.hadoop.hbase.client.ConnectionManager.createConnection(
at org.apache.hadoop.hbase.client.ConnectionManager.createConnectionInternal(
at org.apache.hadoop.hbase.client.HConnectionManager.createConnection(
at org.apache.phoenix.query.HConnectionFactory$HConnectionFactoryImpl.createConnection(
at org.apache.phoenix.query.ConnectionQueryServicesImpl.openConnection(
at org.apache.phoenix.query.ConnectionQueryServicesImpl.access$300(
at org.apache.phoenix.query.ConnectionQueryServicesImpl$
at org.apache.phoenix.query.ConnectionQueryServicesImpl$
at org.apache.phoenix.query.ConnectionQueryServicesImpl.init(
at org.apache.phoenix.jdbc.PhoenixDriver.getConnectionQueryServices(
at org.apache.phoenix.jdbc.PhoenixEmbeddedDriver.createConnection(
at org.apache.phoenix.jdbc.PhoenixDriver.connect(
at net.sourceforge.squirrel_sql.fw.sql.SQLDriverManager.getConnection(
at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.executeConnect(
at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.access$000(
at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand$
at java.util.concurrent.Executors$ Source)
at Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)


Super Collaborator

Please check that you are using the fat client jar from HDP distribution in the properties for Squirrel. It can be found at /usr/hdp/current/phoenix-client/phoenix-client.jar


This is the client jar I have loaded into the squirrel lib directory:

phoenix- It is not the thin client jar


Hi @Dean Geary

I reviewed my actual Squirrel 3.8 configuration and I posted it here:


Figure 1. Phoenix Driver configuration.


Figure 2. Phoenix Alias configuration (Note: Username and Password its not important here, so I used anything in both cases).

If you are going to develop a Java application using Phoenix, take a look to the question loading phoenix table using java.


I attached screenshots of my configuration. I am running the standard Horton 2.6 sandbox VM. I have tried every combination of addresses for the URL. The first on I used was the sandbox IP (mapped to knowing that port forwarding would route it to the Docker. Just for kicks, I also plugged in the Docker IP knowing that it would not be able to address it. Then I saw your config and tried localhost. Nothing worked and I always got the exact same error msg.squirrel-driver.pngsquirrel-alias.pngstack.png


P.S. here is a screenshot to show that Hbase and Pohoenix are up and running...


Can you download the driver again from this path:


And try again.


Sadly, same result!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.