Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

cannot create sqoop job in terminal

New Contributor

Hi all,

I am using the command: 

sqoop job --create job1 --import --connect jdbc:oracle:thin:xxxxx --username xxxxx --password xxxxxxxx --as-parquetfile --target-dir /user/cdh/testgb/raw/adminunits --fields-terminated-by ',' --lines-terminated-by '\n' --table develop.adminunits --m 1 --hive-import --hive-database metdev_testgb --hive-table ADMINUNITS

 

but the ERROR SHOWN IS THIS:

21/09/16 08:21:33 INFO sqoop.Sqoop: Running Sqoop version: 1.4.7-cdh6.3.2
21/09/16 08:21:33 INFO manager.SqlManager: Using default fetchSize of 1000
21/09/16 08:21:33 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.
21/09/16 08:21:33 ERROR tool.BaseSqoopTool: Error parsing arguments for import:
21/09/16 08:21:33 ERROR tool.BaseSqoopTool: Unrecognized argument: sqoop
21/09/16 08:21:33 ERROR tool.BaseSqoopTool: Unrecognized argument: import
21/09/16 08:21:33 ERROR tool.BaseSqoopTool: Unrecognized argument: --connect

 

And similar ones till the end for each parameter.

Please help to resolve this issue.

1 REPLY 1

Cloudera Employee

Hello 

 

Can you try giving space between  -- & import as it is a sub tool name.

 

sqoop job --create job1 -- import --connect jdbc:oracle:thin:xxxxx --username xxxxx --password xxxxxxxx --as-parquetfile --target-dir /user/cdh/testgb/raw/adminunits --fields-terminated-by ',' --lines-terminated-by '\n' --table develop.adminunits --m 1 --hive-import --hive-database metdev_testgb --hive-table ADMINUNITS