Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

cloudera hostname

Solved Go to solution
Highlighted

cloudera hostname

New Contributor

Hello,

I am at below screen where I have to give host names.

 

http://localhost:7180/cmf/express-wizard/hosts

 

I have installed VirtualBox on Mac OS and using Ubuntu 16.

 

Have installed below cloudera-manager.

wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin

 

I am confused what should i give in hostname in the current screen (http://localhost:7180/cmf/express-wizard/hosts)

I tried 127.0.0.1 / localhost/ and ip addres which i got from ifconfiug but none of them is working

Your help will be highly appreciated !!!!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: cloudera hostname

Super Mentor

@Gaurang1 

As you are using VirtualBox to CM so can you please chck if you have configured Port Forwarding in VirtualBox in order to be able to access the port 7180 running inside the VM to outside of VirtualBox?

 

Reference: (from google search) 

https://www.simplified.guide/virtualbox/port-forwarding
https://www.howtogeek.com/122641/how-to-forward-ports-to-a-virtual-machine-and-use-it-as-a-server/

View solution in original post

4 REPLIES 4
Highlighted

Re: cloudera hostname

Super Mentor

@Gaurang1 

As you are using VirtualBox to CM so can you please chck if you have configured Port Forwarding in VirtualBox in order to be able to access the port 7180 running inside the VM to outside of VirtualBox?

 

Reference: (from google search) 

https://www.simplified.guide/virtualbox/port-forwarding
https://www.howtogeek.com/122641/how-to-forward-ports-to-a-virtual-machine-and-use-it-as-a-server/

View solution in original post

Highlighted

Re: cloudera hostname

New Contributor

Thanks @jsensharma 

I have now enable 7180 port forwarding so , I am able to access http://localhost:7180 outside VM (directly in host OS )

 

But i still get the error  "Could not connect to host's SSH service". on the screen of "Specify host for your CDH cluster installation)" . Here SSH port is 22. 

I also configure port forward for 22.

 

 

Highlighted

Re: cloudera hostname

Super Mentor

@Gaurang1 

 

Good to know that after enabling Port forwarding for 7180 port you are able to access the http://localhost:7180 properly  and it is working fine.

 

Regarding your SSH issue , i think you should map the port 22 to something else because your Laptop where you are running virtual Box also might be using that default port 22 

 

If you still face a SSH port access issue while using VirtualBox then it can be discussed as part of. separate thread as the Original issue which you posted in the original thread is resolved.

If your  original is answered then, Please make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Highlighted

Re: cloudera hostname

New Contributor
Don't have an account?
Coming from Hortonworks? Activate your account here