Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

cloudera-scm-server is dead and pid file exists

SOLVED Go to solution

Re: cloudera-scm-server is dead and pid file exists

New Contributor

 after doing this step rm /var/run/cloudera-scm-server.pid  what we do

 

 

Re: cloudera-scm-server is dead and pid file exists

New Contributor

/var/run/cloudera-scm-server.pid

 where we execute this command

 

Re: cloudera-scm-server is dead and pid file exists

New Contributor
/var/log/cloudera-scm-server/cloudera-scm-server.log while execututing this command access permission was denaid

Re: cloudera-scm-server is dead and pid file exists

New Contributor

you has to do it  with root user login

 

or else sudo user login

Re: cloudera-scm-server is dead and pid file exists

New Contributor
go through with my post

Re: cloudera-scm-server is dead and pid file exists

New Contributor
which is mentioned above 13th post

Re: cloudera-scm-server is dead and pid file exists

New Contributor

Hi,
It just occure with me, I fixed it as belows;
1. rm /var/run/cloudera-scm-server.pid
2 service cloudera-scm-server-db stop
3 /etc/rc.d/init.d/postgresql restart ----------------> Fixed in this
or(/etc/init.d/postgresql restart in Ubuntu)
4. service cloudera-scm-server-db start
5. service cloudera-scm-server start..

the problem is postgresql is not running

from:http://grokbase.com/t/cloudera/scm-users/138wj3kf3t/cloudera-scm-server-dead-but-pid-file-exists

Re: cloudera-scm-server is dead and pid file exists

New Contributor

Hi,

 

I fix this issue as ..

 

1) go to the /etc/cloudera-scm-agent/config.ini ---- file  and then update the following parameters in this file according to your servers.

 

## It should not normally be necessary to modify these.
# Port that the CM agent should listen on.
listening_port=9000

# IP Address that the CM agent should listen on.
listening_ip=192.168.0.000    -------------------------------------------------------> need your server IP

# Hostname that the CM agent reports as its hostname. If unset, will be
# obtained in code through something like this:
#
# python -c 'import socket; \
# print socket.getfqdn(), \
# socket.gethostbyname(socket.getfqdn())'
#
listening_hostname=192.168.0.000 ------------------------------------------------> need your server Ip same as above

 

use_tls=1

 

save this setting in config.ini file and then

 

restart cloudera-scm-agent services as 

 

service cloudera-scm-agent restart

 

your issue will resolved...

 

 

Regards,

 

Maroof khan Gandapur

 

 

Re: cloudera-scm-server is dead and pid file exists

New Contributor

check for pid number by using

# ps-ef |grep cloudera-scm-server

# kill -20 <pid number>"

# service iptables stop

# service ip6tables stop

#service cloudera-scm-server restart

#service cloudera-scm-server status

if still it triggering same error

init 6

#service cloudera-scm-server restart

#service cloudera-scm-server status

contact me at amar.sql94@gmail.com