Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

cloudera upgradation problem from 5.48 to 5.9.2

SOLVED Go to solution

cloudera upgradation problem from 5.48 to 5.9.2

Contributor

I have 5 node cluster and using ISILON for hdfs storage and tried to upgrade both isilon onefs and cloudera cluster from 5.4.8 version to 5.9.2 version

 

Below are the commands i issued in the machines before proceed from the cloudera manager UI,

 

step1: sudo service cloudera-scm-server stop

step2: sudo service cloudera-scm-agent stop

step3: Upgrade ISILON (done on isilon machines)

step4: issued command in cloudera manager server machine

sudo yum clean all
sudo yum upgrade cloudera-manager-daemons cloudera-manager-server
step5: issued command in cloudera manager agent machines
sudo yum clean all
sudo yum upgrade cloudera-manager-agent cloudera-manager-daemons
step6: sudo service cloudera-scm-server start
step7: 
sudo service cloudera-scm-agent next_stop_hard
sudo service cloudera-scm-agent restart
 
once login into the cloudera manager getting below log once try to restart the cloudera management service
 
 
ERROR 1110082230@scm-web-22:org.mortbay.log: /cmf/role/24/tail
java.lang.NullPointerException
at org.springframework.web.servlet.view.RedirectView.appendQueryProperties(RedirectView.java:252)
at org.springframework.web.servlet.view.RedirectView.renderMergedOutputModel(RedirectView.java:225)
at org.springframework.web.servlet.view.AbstractView.render(AbstractView.java:250)
at org.springframework.web.servlet.DispatcherServlet.render(DispatcherServlet.java:1047)
at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:817)
at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:719)
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:669)
at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:574)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:575)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1221)
at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:78)
at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:131)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
 
 
 
 please help me to solve it.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: cloudera upgradation problem from 5.48 to 5.9.2

Contributor

I missed to install Cloudera manager  agent in the Cloudera manager server instance. Once I installed the problem has solved

2 REPLIES 2

Re: cloudera upgradation problem from 5.48 to 5.9.2

Contributor

I missed to install Cloudera manager  agent in the Cloudera manager server instance. Once I installed the problem has solved

Re: cloudera upgradation problem from 5.48 to 5.9.2

Community Manager

Congratulations on solving your issue and thanks for sharing the solution. Best of luck moving forward. :)



Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum