Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
02-20-2023
12:16 PM
- last edited on
04-21-2026
12:43 AM
by
GrazittiAPI
Please could someone help what can be done here , i'm getting attached error while try to set up the cluster
Created 02-21-2023 02:54 AM
Can you please help with full stack trace for queue manager?
Created 02-21-2023 05:20 AM
Tue Feb 21 00:59:52 IST 2023
JAVA_HOME=/usr/java/jdk1.8.0_232-cloudera
Using -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/queuemanager_queuemanager-QUEUEMANAGER_STORE-d9ddbb5b382b3332696df1de7aa6742a_pid14918.hprof -XX:OnOutOfMemoryError=/opt/cloudera/cm-agent/service/common/killparent.sh as CSD_JAVA_OPTS
Using /var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE as conf dir
Using scripts/control.sh as process script
CONF_DIR=/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE
CMF_CONF_DIR=
Starting the YARN Queue Manager config server on port []
00:59:56.774 [main] INFO org.eclipse.jetty.util.log - Logging initialized @3438ms to org.eclipse.jetty.util.log.Slf4jLog
00:59:56.917 [main] INFO i.d.server.DefaultServerFactory - Registering jersey handler with root path prefix: /
00:59:56.920 [main] INFO i.d.server.DefaultServerFactory - Registering admin handler with root path prefix: /
00:59:56.922 [main] INFO c.c.c.utils.WebappProperties - Reading '/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE/conf//webapp.properties' ....
00:59:56.931 [main] INFO c.c.c.utils.WebappProperties - Read 'webapp.properties' contents : {config_service_db_loc=jdbc:h2:~/config-service, kerberos.auth.enabled=false, queuemanager_store_keystore_file=, queuemanager_store_password=, queuemanager_store_ssl_enabled=false, yarn_queuemanager_store_log_dir=/var/log/yarn/queuemanager}
00:59:56.934 [main] INFO c.c.c.ConfigServiceApplication - Check for admin password update.
00:59:56.934 [main] INFO c.c.c.utils.QueryUserTable - Update system admin password for h2 database.
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:00.145 [main] INFO c.c.c.utils.QueryUserTable - Existing database uses a non-empty password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:02.720 [main] ERROR c.c.c.utils.QueryUserTable - Admin password is not recoverable. Please try to manually update your H2 password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
01:00:02.720 [main] ERROR c.c.c.ConfigServiceApplication - Unable to update admin password. Please try updating password manually on your H2 instance.
Tue Feb 21 01:00:05 IST 2023
JAVA_HOME=/usr/java/jdk1.8.0_232-cloudera
Using -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/queuemanager_queuemanager-QUEUEMANAGER_STORE-d9ddbb5b382b3332696df1de7aa6742a_pid15046.hprof -XX:OnOutOfMemoryError=/opt/cloudera/cm-agent/service/common/killparent.sh as CSD_JAVA_OPTS
Using /var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE as conf dir
Using scripts/control.sh as process script
CONF_DIR=/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE
CMF_CONF_DIR=
Starting the YARN Queue Manager config server on port []
01:00:08.281 [main] INFO org.eclipse.jetty.util.log - Logging initialized @2678ms to org.eclipse.jetty.util.log.Slf4jLog
01:00:08.396 [main] INFO i.d.server.DefaultServerFactory - Registering jersey handler with root path prefix: /
01:00:08.399 [main] INFO i.d.server.DefaultServerFactory - Registering admin handler with root path prefix: /
01:00:08.401 [main] INFO c.c.c.utils.WebappProperties - Reading '/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE/conf//webapp.properties' ....
01:00:08.410 [main] INFO c.c.c.utils.WebappProperties - Read 'webapp.properties' contents : {config_service_db_loc=jdbc:h2:~/config-service, kerberos.auth.enabled=false, queuemanager_store_keystore_file=, queuemanager_store_password=, queuemanager_store_ssl_enabled=false, yarn_queuemanager_store_log_dir=/var/log/yarn/queuemanager}
01:00:08.413 [main] INFO c.c.c.ConfigServiceApplication - Check for admin password update.
01:00:08.413 [main] INFO c.c.c.utils.QueryUserTable - Update system admin password for h2 database.
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:11.156 [main] INFO c.c.c.utils.QueryUserTable - Existing database uses a non-empty password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:13.743 [main] ERROR c.c.c.utils.QueryUserTable - Admin password is not recoverable. Please try to manually update your H2 password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
01:00:13.743 [main] ERROR c.c.c.ConfigServiceApplication - Unable to update admin password. Please try updating password manually on your H2 instance.
Tue Feb 21 01:00:17 IST 2023
JAVA_HOME=/usr/java/jdk1.8.0_232-cloudera
Using -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/queuemanager_queuemanager-QUEUEMANAGER_STORE-d9ddbb5b382b3332696df1de7aa6742a_pid15197.hprof -XX:OnOutOfMemoryError=/opt/cloudera/cm-agent/service/common/killparent.sh as CSD_JAVA_OPTS
Using /var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE as conf dir
Using scripts/control.sh as process script
CONF_DIR=/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE
CMF_CONF_DIR=
Starting the YARN Queue Manager config server on port []
01:00:21.630 [main] INFO org.eclipse.jetty.util.log - Logging initialized @3464ms to org.eclipse.jetty.util.log.Slf4jLog
01:00:21.759 [main] INFO i.d.server.DefaultServerFactory - Registering jersey handler with root path prefix: /
01:00:21.762 [main] INFO i.d.server.DefaultServerFactory - Registering admin handler with root path prefix: /
01:00:21.764 [main] INFO c.c.c.utils.WebappProperties - Reading '/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE/conf//webapp.properties' ....
01:00:21.774 [main] INFO c.c.c.utils.WebappProperties - Read 'webapp.properties' contents : {config_service_db_loc=jdbc:h2:~/config-service, kerberos.auth.enabled=false, queuemanager_store_keystore_file=, queuemanager_store_password=, queuemanager_store_ssl_enabled=false, yarn_queuemanager_store_log_dir=/var/log/yarn/queuemanager}
01:00:21.777 [main] INFO c.c.c.ConfigServiceApplication - Check for admin password update.
01:00:21.778 [main] INFO c.c.c.utils.QueryUserTable - Update system admin password for h2 database.
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:24.760 [main] INFO c.c.c.utils.QueryUserTable - Existing database uses a non-empty password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:27.330 [main] ERROR c.c.c.utils.QueryUserTable - Admin password is not recoverable. Please try to manually update your H2 password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
01:00:27.330 [main] ERROR c.c.c.ConfigServiceApplication - Unable to update admin password. Please try updating password manually on your H2 instance.
Tue Feb 21 01:00:32 IST 2023
JAVA_HOME=/usr/java/jdk1.8.0_232-cloudera
Using -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/queuemanager_queuemanager-QUEUEMANAGER_STORE-d9ddbb5b382b3332696df1de7aa6742a_pid15329.hprof -XX:OnOutOfMemoryError=/opt/cloudera/cm-agent/service/common/killparent.sh as CSD_JAVA_OPTS
Using /var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE as conf dir
Using scripts/control.sh as process script
CONF_DIR=/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE
CMF_CONF_DIR=
Starting the YARN Queue Manager config server on port []
01:00:35.475 [main] INFO org.eclipse.jetty.util.log - Logging initialized @2638ms to org.eclipse.jetty.util.log.Slf4jLog
01:00:35.592 [main] INFO i.d.server.DefaultServerFactory - Registering jersey handler with root path prefix: /
01:00:35.594 [main] INFO i.d.server.DefaultServerFactory - Registering admin handler with root path prefix: /
01:00:35.596 [main] INFO c.c.c.utils.WebappProperties - Reading '/var/run/cloudera-scm-agent/process/98-queuemanager-QUEUEMANAGER_STORE/conf//webapp.properties' ....
01:00:35.606 [main] INFO c.c.c.utils.WebappProperties - Read 'webapp.properties' contents : {config_service_db_loc=jdbc:h2:~/config-service, kerberos.auth.enabled=false, queuemanager_store_keystore_file=, queuemanager_store_password=, queuemanager_store_ssl_enabled=false, yarn_queuemanager_store_log_dir=/var/log/yarn/queuemanager}
01:00:35.609 [main] INFO c.c.c.ConfigServiceApplication - Check for admin password update.
01:00:35.609 [main] INFO c.c.c.utils.QueryUserTable - Update system admin password for h2 database.
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:38.336 [main] INFO c.c.c.utils.QueryUserTable - Existing database uses a non-empty password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
org.h2.message.DbException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "org.h2.message.DbException: Error while creating file ""/var/lib/hadoop-yarn"" [90062-198]" [90034-198]
01:00:40.901 [main] ERROR c.c.c.utils.QueryUserTable - Admin password is not recoverable. Please try to manually update your H2 password.
org.h2.jdbc.JdbcSQLNonTransientException: Error while creating file "/var/lib/hadoop-yarn" [90062-198]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:502)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.store.fs.FilePathDisk.createDirectory(FilePathDisk.java:290)
at org.h2.store.fs.FileUtils.createDirectory(FileUtils.java:42)
at org.h2.store.fs.FileUtils.createDirectories(FileUtils.java:312)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:74)
at org.h2.engine.Database.getPageStore(Database.java:2740)
at org.h2.engine.Database.open(Database.java:769)
at org.h2.engine.Database.openDatabase(Database.java:319)
at org.h2.engine.Database.<init>(Database.java:313)
at org.h2.engine.Engine.openSession(Engine.java:69)
at org.h2.engine.Engine.openSession(Engine.java:201)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:178)
at org.h2.engine.Engine.createSession(Engine.java:161)
at org.h2.engine.Engine.createSession(Engine.java:31)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:336)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:124)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:103)
at org.h2.Driver.connect(Driver.java:69)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at com.cloudera.configservice.utils.QueryUserTable.updatePassword(QueryUserTable.java:37)
at com.cloudera.configservice.ConfigServiceApplication.createJpaModule(ConfigServiceApplication.java:131)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:84)
at com.cloudera.configservice.ConfigServiceApplication.run(ConfigServiceApplication.java:65)
at io.dropwizard.cli.EnvironmentCommand.run(EnvironmentCommand.java:59)
at io.dropwizard.cli.ConfiguredCommand.run(ConfiguredCommand.java:98)
at io.dropwizard.cli.Cli.run(Cli.java:78)
at io.dropwizard.Application.run(Application.java:94)
at com.cloudera.configservice.ConfigServiceApplication.main(ConfigServiceApplication.java:72)
01:00:40.901 [main] ERROR c.c.c.ConfigServiceApplication - Unable to update admin password. Please try updating password manually on your H2 instance.
Created 03-08-2023 06:28 AM
to resolve problem you need to create folder
sudo mkdir /var/lib/hadoop-yarn/
sudo chmod +077 /var/lib/hadoop-yarn/
sudo chown yarn:hadoop /var/lib/hadoop-yarn/