Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Solved Go to solution

codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Contributor

Hi, I have installed the Apache Metron 0.3 all other options like fastcapa-test-platform, full-dev-platform, quick-dev-platform fails after downloading the vagrant box and seems to have bug in ansible configs. And fails to execute all service successfully. Never the less codelab-platform seems to work perfectly. Only problem I am encountering is when logged in vagrant machine using ssh. I see 0.2.0BETA instead of 0.3 (Any Suggestion idea why ?) cd /usr/metron/0.2.0BETA/

1 ACCEPTED SOLUTION

Accepted Solutions

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Contributor

It turned out to be wrong checkout version. I downloaded the code from Github Metron Release section and all went good.

Its working now.

5 REPLIES 5

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Super Collaborator

Hey, @Farrukh Naveed Anjum can you run vagrant box update and see if it resolves your issue?

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Contributor

Hi,

I tried to run the following command and its still giving that 0.2.0 is latest ?

[root@centos16 codelab-platform]# vagrant box update
==> node1: Checking for updates to 'metron/codelab'
  node1: Latest installed version: 0.2.0
  node1: Version constraints: 
  node1: Provider: virtualbox
==> node1: Box 'metron/codelab' (v0.2.0) is running the latest version.

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Super Collaborator

On my setup, I see this..

➜  quick-dev-platform git:(master) ✗ vagrant box update
 Running with ansible-tags: ["ambari-agent", "hdp-deploy", "metron"]
 Running with ansible-skip-tags: ["solr", "yaf"]
==> node1: Checking for updates to 'metron/hdp-base'
    node1: Latest installed version: 0.0.3
    node1: Version constraints:
    node1: Provider: virtualbox
==> node1: Box 'metron/hdp-base' (v0.0.3) is running the latest version.
➜  quick-dev-platform git:(master) ✗ pwd
~/incubator-metron/metron-deployment/vagrant/quick-dev-platform

Can you get the latest git repo and try again?

Highlighted

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

New Contributor

Sorry for formatting, I'm mobile.

What is the error, and what's your host OS? Try running the following where you run `vagrant up`

sed -i '/\[ssh_connection\]/a scp_if_ssh = True' ./ansible.cfg

Re: codelab-platform in Apache Metron 0.3 (Vagrant VM Seems to be using 0.2BETA)

Contributor

It turned out to be wrong checkout version. I downloaded the code from Github Metron Release section and all went good.

Its working now.