Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

disabled ambari ssl now cannot login

Solved Go to solution
Highlighted

disabled ambari ssl now cannot login

New Contributor

I found it necessary to troubleshoot a problem enabling kerberos to modify the ambari server and cluster boxes /etc/hostname from name.example.com to name.corp.example.com

I also edited the /etc/hosts on all to reflect accordingly.

I also ran ambari-server setup-security and option 1 to DISABLE the https.

Enter choice, (1-5): 1 Do you want to disable HTTPS [y/n] (n)? y Ambari server URL changed. To make use of the Tez View in Ambari please update the property tez.tez-ui.history-url.base in tez-site Adjusting ambari-server permissions and ownership... NOTE: Restart Ambari Server to apply changes ("ambari-server restart|stop+start")

restarted the ambari service #ambari-server restart|

Now I get the login page on port 8- butif I try to login as admin the screen just freezes and mouse cursor becomes circle with line through it.

Any suggestions welcome to get back to admin able to log in.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: disabled ambari ssl now cannot login

Super Mentor

@Tom Burke

It may be browser caching issue. So please try this:

1. Open the Web Browser in "Private Mode" (In Firefox) or "Incognito Mode" (in Chrome) and then try again.

2. If still you face the same issue then please try this to edit the "/etc/ambari-server/ambari.properties" file and then unset the value of the following two properties:

FROM
------
http.strict-transport-security=max-age=31536000 
views.http.strict-transport-security=max-age=31536000 

TO
------
http.strict-transport-security=max-age=
views.http.strict-transport-security=max-age=



The restart ambari-server and then try accessing the UI again

# ambari-server restart

.

1 REPLY 1

Re: disabled ambari ssl now cannot login

Super Mentor

@Tom Burke

It may be browser caching issue. So please try this:

1. Open the Web Browser in "Private Mode" (In Firefox) or "Incognito Mode" (in Chrome) and then try again.

2. If still you face the same issue then please try this to edit the "/etc/ambari-server/ambari.properties" file and then unset the value of the following two properties:

FROM
------
http.strict-transport-security=max-age=31536000 
views.http.strict-transport-security=max-age=31536000 

TO
------
http.strict-transport-security=max-age=
views.http.strict-transport-security=max-age=



The restart ambari-server and then try accessing the UI again

# ambari-server restart

.