Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

error while deploying new cluster

error while deploying new cluster

New Contributor

Hi, I need help in understanding the error Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

3 REPLIES 3
Highlighted

Re: error while deploying new cluster

Super Mentor

@eugene de Fikh

If you can provide more detailed exception / error then it will help in getting this issue resolved much quicker.

Based on the error message that you posted 'Failed to retrieve the server's certificate'

It looks like ambari agents might not be able to contact ambari server. So please check if ambari Agent machines can resolve ambaris erver host aand can communicate on 8440 & 8441 ports?

Please try running the following commands from agent machine to verify if they are able to connect to ambari Server?

# telnet  $AMBARI_HOSTNAME 8440
# telnet  $AMBARI_HOSTNAME 8441

.

If not then

1. please check if agents machine can resolve ambari server hostname/FQDN? Check:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.2.2/bk_ambari-installation/content/edit_the_hos...

2. Please check if ambari server host has "iptables" disabled.

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.2.2/bk_ambari-installation/content/configuring_...

Highlighted

Re: error while deploying new cluster

Super Mentor
Highlighted

Re: error while deploying new cluster

New Contributor

Hi @Jay Kumar SenSharma, where can I find detailed logs, all other items are checked off and I see no obvious network issues, exceot that ambari server does not have ports 8440 or 8441 listeing on

Don't have an account?
Coming from Hortonworks? Activate your account here