Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

errors when adding node to 5.10

errors when adding node to 5.10

New Contributor

I am trying to install 5.10 on a 6 node cluster. I used the "Automatically install CDH 5 with a Cloudera Manager Deployment." option to get cloudera manager up on node 1. I was able to log in to cloudera manager but am having issues adding another node. When I try to add another node, I get the error below. Any help is greatly appriciated. 

 

Installing cloudera-manager-agent package...

section BEGIN yum list installed cloudera-manager-agent

Loaded plugins: security

Error: No matching Packages to list

END (1)

BEGIN yum info cloudera-manager-agent

Loaded plugins: security

Available Packages

Name : cloudera-manager-agent

Arch : x86_64

Version : 5.10.0

Release : 1.cm5100.p0.85.el6

Size : 9.0 M

Repo : cloudera-manager

Summary : The Cloudera Manager Agent

URL : http://www.cloudera.com

License : Proprietary

Description : The Cloudera Manager Agent.

:

: The Agent is deployed to machines running services managed by

: Cloudera Manager.

 

END (0)

Version : 5.10.0

Release : 1.cm5100.p0.85.el6

BEGIN yum -y install cloudera-manager-agent

Loaded plugins: security

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package cloudera-manager-agent.x86_64 0:5.10.0-1.cm5100.p0.85.el6 will be installed

--> Processing Dependency: fuse for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: mod_ssl for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: MySQL-python for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: httpd for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: fuse-libs for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: python-psycopg2 for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Processing Dependency: openssl-devel for package: cloudera-manager-agent-5.10.0-1.cm5100.p0.85.el6.x86_64

--> Running transaction check

---> Package MySQL-python.x86_64 0:1.2.3-0.3.c1.1.el6 will be installed

---> Package fuse.x86_64 0:2.8.3-4.0.2.el6 will be installed

---> Package fuse-libs.x86_64 0:2.8.3-4.0.2.el6 will be installed

---> Package httpd.x86_64 0:2.2.15-39.0.1.el6 will be installed

--> Processing Dependency: httpd-tools = 2.2.15-39.0.1.el6 for package: httpd-2.2.15-39.0.1.el6.x86_64

--> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-39.0.1.el6.x86_64

--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.2.15-39.0.1.el6.x86_64

--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.2.15-39.0.1.el6.x86_64

---> Package mod_ssl.x86_64 1:2.2.15-39.0.1.el6 will be installed

---> Package openssl-devel.x86_64 0:1.0.1e-30.el6_6.2 will be installed

--> Processing Dependency: openssl = 1.0.1e-30.el6_6.2 for package: openssl-devel-1.0.1e-30.el6_6.2.x86_64

--> Processing Dependency: zlib-devel for package: openssl-devel-1.0.1e-30.el6_6.2.x86_64

--> Processing Dependency: krb5-devel for package: openssl-devel-1.0.1e-30.el6_6.2.x86_64

---> Package python-psycopg2.x86_64 0:2.0.14-2.el6 will be installed

--> Running transaction check

---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed

---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed

---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed

---> Package httpd-tools.x86_64 0:2.2.15-39.0.1.el6 will be installed

---> Package krb5-devel.x86_64 0:1.10.3-33.el6 will be installed

--> Processing Dependency: krb5-libs = 1.10.3-33.el6 for package: krb5-devel-1.10.3-33.el6.x86_64

--> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-33.el6.x86_64

--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-33.el6.x86_64

--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-33.el6.x86_64

---> Package openssl.i686 0:1.0.1e-30.el6_6.2 will be installed

--> Processing Dependency: libz.so.1 for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libdl.so.2 for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: openssl-1.0.1e-30.el6_6.2.i686

--> Processing Dependency: libc.so.6 for package: openssl-1.0.1e-30.el6_6.2.i686

---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed

--> Running transaction check

---> Package glibc.i686 0:2.12-1.166.el6_7.7 will be installed

--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.166.el6_7.7.i686

--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.166.el6_7.7.i686

---> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be installed

---> Package krb5-libs.i686 0:1.10.3-33.el6 will be installed

--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-33.el6.i686

--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-33.el6.i686

--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-33.el6.i686

---> Package libcom_err.i686 0:1.42.8-1.0.1.el6 will be installed

---> Package libcom_err-devel.x86_64 0:1.42.8-1.0.1.el6 will be installed

---> Package libselinux-devel.x86_64 0:2.0.94-5.8.el6 will be installed

--> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.8.el6.x86_64

--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.8.el6.x86_64

---> Package zlib.i686 0:1.2.3-29.el6 will be installed

--> Running transaction check

---> Package keyutils-libs.i686 0:1.4-5.el6 will be installed

---> Package libselinux.i686 0:2.0.94-5.8.el6 will be installed

---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed

---> Package nss-softokn-freebl.i686 0:3.14.3-17.el6 will be installed

--> Finished Dependency Resolution

Error: Multilib version problems found. This often means that the root

cause is something else and multilib version checking is just

pointing out that there is a problem. Eg.:

 

1. You have an upgrade for nss-softokn-freebl which is missing some

dependency that another package requires. Yum is trying to

solve this by installing an older version of nss-softokn-freebl of the

different architecture. If you exclude the bad architecture

yum will tell you what the root cause is (which package

requires what). You can try redoing the upgrade with

--exclude nss-softokn-freebl.otherarch ... this should give you an error

message showing the root cause of the problem.

 

2. You have multiple architectures of nss-softokn-freebl installed, but

yum can only see an upgrade for one of those arcitectures.

If you don't want/need both architectures anymore then you

can remove the one with the missing update and everything

will work.

 

3. You have duplicate versions of nss-softokn-freebl installed already.

You can use "yum check" to get yum show these errors.

 

...you can also use --setopt=protected_multilib=false to remove

this checking, however this is almost never the correct thing to

do as something else is very likely to go wrong (often causing

much more problems).

 

Protected multilib versions: nss-softokn-freebl-3.14.3-17.el6.i686 != nss-softokn-freebl-3.14.3-22.el6_6.x86_64

Error: Protected multilib versions: libcom_err-1.42.8-1.0.1.el6.i686 != libcom_err-1.42.8-1.0.2.el6.x86_64

Error: Protected multilib versions: openssl-1.0.1e-30.el6_6.2.i686 != openssl-1.0.1e-30.el6_6.5.x86_64

Error: Protected multilib versions: krb5-libs-1.10.3-33.el6.i686 != krb5-libs-1.10.3-42.el6.x86_64

END (1)

remote package cloudera-manager-agent could not be installed, giving up

waiting for rollback request

section

 

2 REPLIES 2

Re: errors when adding node to 5.10

New Contributor

Did you ever get this fixed? I'm runnig into the same problem, different RPM though. Trying to upgrade a required x86_64 rpm to the i686 version and failing due to dependencies. 

Re: errors when adding node to 5.10

Super Guru

Hi @smtompk

 

The error is coming from your OS's yum command.  Web searches reveal that it is likely caused by trying to install both 32 and 64bit versions of the same package. Once the issue is resolved the agent install should be able to proceed.

 

-Ben

Don't have an account?
Coming from Hortonworks? Activate your account here