Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

flume kafka sink for SASL_SSL protocol is not working

Solved Go to solution

flume kafka sink for SASL_SSL protocol is not working

New Contributor

I have been trying to enable SASL_SSL protocol for kafka sink and getting error . I attached my flume conf and flume log file here. Could anyone please tell me whats the reason?stacktrace.txtkafka-sasl-ssl-sink.txt

1 ACCEPTED SOLUTION

Accepted Solutions

Re: flume kafka sink for SASL_SSL protocol is not working

Contributor

@Mehedi Hasan SASL_SSL is not available in the older kafka consumer api. The new kafka consumer api integration is in Flume v.1.7.0 as noted here: https://issues.apache.org/jira/browse/FLUME-2821. What is the version of Flume you are using?

2 REPLIES 2

Re: flume kafka sink for SASL_SSL protocol is not working

Contributor

@Mehedi Hasan SASL_SSL is not available in the older kafka consumer api. The new kafka consumer api integration is in Flume v.1.7.0 as noted here: https://issues.apache.org/jira/browse/FLUME-2821. What is the version of Flume you are using?

Re: flume kafka sink for SASL_SSL protocol is not working

New Contributor

@Shashank Chandhok

i am using the one which is shipped with HDP 2.6 that is flume 1.52. with added feature of 1.6