Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hadoop - oozie job configuration App directory not exits?

Solved Go to solution

hadoop - oozie job configuration App directory not exits?

New Contributor

After running the oozie job in hue dashboard, it shows the following error

"App directory doesn't exits"

please try to solve this error.

5255-untitled.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: hadoop - oozie job configuration App directory not exits?

In addition to Kuldeep's comment check your error message and verify your directory present in hdfs location and verify your application path oozie.wf.application.path=

3 REPLIES 3

Re: hadoop - oozie job configuration App directory not exits?

Super Guru

@Manikandan Durairaj

Can you please confirm if you have your user directory(/user/mani) setup in your dtap filesystem? if its not there then please go ahead and create one.

Re: hadoop - oozie job configuration App directory not exits?

In addition to Kuldeep's comment check your error message and verify your directory present in hdfs location and verify your application path oozie.wf.application.path=

Highlighted

Re: hadoop - oozie job configuration App directory not exits?

Expert Contributor

I am not sure about Hue but from the terminal it can be fixed by exporting the correct oozie server.

Use this command to export the oozie url.

export OOZIE_URL=http://someip:11000/oozie

To get this oozie url you need to use hue to connect you cluster and navigate to Workflows where you can find a tab called oozie. Inside this you should see gauges where a lot of properties will be listed. Look for the property oozie.servers.

Don't have an account?
Coming from Hortonworks? Activate your account here