Support Questions
Find answers, ask questions, and share your expertise

hbase master failed to start after disabling hbase plugin for ranger

Contributor

we disabled hbase plugin for ranger and restarted the Hbase but hbase master failed to restart.

Tried the solution mentioned in one of the post to restart HDFS, YARN and HBASE...nothing works:(

error message:

016-07-22 15:36:58,585 FATAL [RBCDHADA112:60000.activeMasterManager] master.HMaster: Unhandled exception. Starting shutdown . org.apache.hadoop.security.AccessControlException: Permission denied: user=hbase, access=READ, inode="/apps/hbase/data/data/ hbase/meta/.tabledesc/.tableinfo.0000000002":hdfs:hdfs:-rw-r----- at org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.check(FSPermissionChecker.java:319) at org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkPermission(FSPermissionChecker.java:219) at org.apache.hadoop.hdfs.server.namenode.FSPermissionChecker.checkPermission(FSPermissionChecker.java:190) at org.apache.hadoop.hdfs.server.namenode.FSDirectory.checkPermission(FSDirectory.java:1771) at org.apache.hadoop.hdfs.server.namenode.FSDirectory.checkPermission(FSDirectory.java:1755) at org.apache.hadoop.hdfs.server.namenode.FSDirectory.checkPathAccess(FSDirectory.java:1729) at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocationsInt(FSNamesystem.java:1823) at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocations(FSNamesystem.java:1792) at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocations(FSNamesystem.java:1705) at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.getBlockLocations(NameNodeRpcServer.java:588) at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.getBlockLocations(ClientNamenodePr otocolServerSideTranslatorPB.java:365) at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(Cl

1 ACCEPTED SOLUTION

Contributor

Looks like after you disable the hbase plugin for ranger, the owner for /data/apps/data is HDFS is not getting changed to hbase for ACL fallback to work. so I changed the owner to hbase and it worked

View solution in original post

4 REPLIES 4

Hi @AR

Firstly please check if Hbase still has XaSecureAuthorization Coprocessor conf inside hbase-site.xml. Look for below properties. If its there then kindly remove it from through UI and restart the Hbase services and then check if underlining HDFS has correct permsiion and see if that resolve the issue

hbase.coprocessor.master.classes

hbase.coprocessor.region.classes

Contributor

I disabled the hbase plugin and ambari prompted with the above classed and restarted it didnt work. please see below the steps I did. Thanks Yadav for your reply.

Ohh great, may be my updated answer didn't reflected one time 🙂 Anyway I have accepted your answer. Thanks for updating.

Contributor

Looks like after you disable the hbase plugin for ranger, the owner for /data/apps/data is HDFS is not getting changed to hbase for ACL fallback to work. so I changed the owner to hbase and it worked

; ;