Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

hive llap connection error

avatar
Contributor

Hi experts,

I recently installed hive2.3.8 and trying to enable LLAP.

I am getting the below error.

beeline> !connect jdbc:hive2://test01.domain.com:2181,test02.domain.com:2181,test03.domain.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2-hive2
Connecting to jdbc:hive2://test01.domain.com:2181,test02.domain.com:2181,test03.domain.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2-hive2
Enter username for jdbc:hive2://test01.domain.com:2181,test02.domain.com:2181,test03.domain.com:2181/:
Enter password for jdbc:hive2://test01.domain.com:2181,test02.domain.com:2181,test03.domain.com:2181/:
21/03/24 20:34:01 [main]: INFO jdbc.HiveConnection: Connected to test02.domain.com:10500
21/03/24 20:34:01 [main]: WARN jdbc.HiveConnection: Failed to connect to test02.domain.com:10500
21/03/24 20:34:01 [main]: ERROR jdbc.Utils: Unable to read HiveServer2 configs from ZooKeeper
Error: Could not open client transport for any of the Server URI's in ZooKeeper: Failed to open new session: java.lang.IllegalArgumentException: hive configuration hive.server2.thrift.resultset.default.fetch.size does not exists. (state=08S01,code=0)
beeline>

 

Any help is much appreciated.

 

Thanks,

1 ACCEPTED SOLUTION

avatar
Expert Contributor
4 REPLIES 4

avatar
Expert Contributor

avatar
Contributor

Thanks Daming Xue for the response.

I previously saw this post and my understanding is that the user tried to downgrade his hive to 2.2 and it worked.

 

Do you know where I can download the binaries for hive 2.2 as I am trying to install it from open source?

 

Also here is the hive version:
[root@test ~]# /usr/local/apache-hive-2.3.8-src/packaging/target/apache-hive-2.3.8-bin/apache-hive-2.3.8-bin/bin/hive --version
Hive 2.3.8
Git file:///usr/local/apache-hive-2.3.8-src -r Unknown
Compiled by root on Mon Mar 22 17:20:19 CDT 2021
From source with checksum d4bb475f3303053b26c5cf63f4fc68a1

And here is the "hive-jdbc-xxx.jar"

/usr/local/apache-hive-2.3.8-src/packaging/target/apache-hive-2.3.8-bin/apache-hive-2.3.8-bin/lib/hive-jdbc-2.3.8.jar

 

avatar
Expert Contributor

You can try to download from Apache.org

 

https://archive.apache.org/dist/hive/

avatar
Contributor

Thanks @Daming Xue  for the response.

So i tried installing Hive 2.2 and it worked.

 

Do you know how I can test hive LLAP vs regular hiveserver2 to see the difference?

Any good hiveserver2 queries or something so I can test the LLAP setup vs hiveserver2?

 

Thanks,