Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hive llap views strange behaviour

hive llap views strange behaviour

I am facing very strange behavior on hive llap . When I change database from default to some other data then for one user

Under tables there is statistics tab which is available for he user but for different user it is not available and for another one

its shows "statistics not supported for partitioned table in hiveserver version 2.1 " but when I change user on the same environment it is working fine .

5 REPLIES 5

Re: hive llap views strange behaviour

Super Mentor

@Anurag Mishra

Can you please check if you have enabled the "Use Interactive Mode" for your Hive View 2.0 ?

Login to Ambari UI --> admin (Drop down) --> "Manage Ambari" -->  "Views" -->  "Hive" -->  "Hive View 2.0"


Click on "Settings" --> "Edit" then change the Set "Use Interactive Mode*" to "true"

.

Logout and login back to Ambari or try restarting the server once and then check the view again.

Re: hive llap views strange behaviour

@Jay Kumar SenSharma

value for Use Interactive Mode is already set to true .

Re: hive llap views strange behaviour

@Jay Kumar SenSharma

Hi Jay,I am getting statistics tab for tables but for views I am not getting the statistics tab

Re: hive llap views strange behaviour

@Jay Kumar SenSharma

Hi Jay,I am getting statistics tab for tables but for views I am not getting the statistics tab

Re: hive llap views strange behaviour

@Jay Kumar SenSharma

can you please explain what is user interactive mode or what it really does when we set its value to true .

This worked for my different cluster setting its value to true .