Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hive view is not accessible & giving errors

hive view is not accessible & giving errors

Contributor

Hive view is not loading and giving error for ATS test & Hiveserver test. It was working fine previously

Its HDP2.4 version. Also hiveserver2 is not working for the cluster.

kindly find the attached file for reference.hiveview.png

plz help if possible.

@Jay SenSharma

3 REPLIES 3

Re: hive view is not accessible & giving errors

Super Mentor

@hardik desai

Is this a kerberized environment ?

Can you please share the screenshot configuration of your "Manage Ambari" --> "Views" --> "Hive View"

Also if you see any error in the ?var/log/ambari-server/ambari-server.log" as soon as you see this message on ambari UI?

Also we see that is says "Can not connect to Hive" So are you sure that the Hive Services are running fine and are you able to run the "HIve Service Checks" properly from

Ambari UI --> HIve --> "Service Action" --.> "Run Service Check"

.

Re: hive view is not accessible & giving errors

Contributor

Hi Jay SenSharma, thanks for respond.

its not kerberized cluster. I have attached the screenshot here, plz find it. view.png

I am not able to run service check for Hive as the hiveserver2 is not working constantly.

also find attached file of hiveserver2 error logs.hiveserver2log.txt

It was working fine till now.

Re: hive view is not accessible & giving errors

Super Mentor

@hardik desai

Your attached "hiveserver2.log" indicates that it is shutdown ... in that case it is not HiveView issue. You need to first make sure that hiveserver2 is up and running fine and the Hive Service check runs fine, Then you can try accessing it via Hive View.

SHUTDOWN_MSG: Shutting down HiveServer2 at slave1.HOSTNAME.com/10.10.10.5

.