Support Questions
Find answers, ask questions, and share your expertise

how to apply a hotfix for zeppelin installed from HDP 2.5

how to apply a hotfix for zeppelin installed from HDP 2.5

Explorer

We have the Zeppelin version 0.6.2 installed and running part of the HDP 2.5 stack. We noticed that we could not delete any paragraphs from the zeppelin notebooks created.

I do see a fix available for this bug:

https://issues.apache.org/jira/browse/ZEPPELIN-1033

Is there a way that I can apply a hotfix for zeppelin using Ambari or from the backend?

I understand the easier solution is to upgrade zeppelin to 0.7, but currently we are not ready to do the upgrade the HDP stack yet.

Any suggestions.

1 REPLY 1

Re: how to apply a hotfix for zeppelin installed from HDP 2.5

Contributor

Anitha R

Hotfix can only be provided by Hortonworks support. If you have support, please create a case and request for Hotfix patch for this bug.

Recommended patching process is to apply the Hotfix patch with ambari upgrade. It will apply patch only the Zeepline binaries. If that is not feasible, request support if JAR patch replacement an option for this bug.