Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

how to modify dfs.permissions.superusergroup in HDP 2.6.3



I cannot find dfs.permissions.superusergroup via ambari (HDFS-->config) in HDP 2.6.3

When I search "dfs.permissions" I see only the parameter "dfs.permissions.enabled"

If i try to add it to the custom hdfs-site I get "Line 1: Property "dfs.permissions.superusergroup" is already defined in this configuration file"

Checking on the local file system I do see that the parameter exists but I cannot modify it via ambari.

I have cluster with HDP 2.6.1 and it is modifiable there.

OS is RHEL 7.3

Any help will be appriciated.



To me, this seems to be a bug. I tried to report it against Ambari:

Maybe it is related to this fix?


Is there a workaround for this problem, which doesn't involve upgrade/downgrade?


@Poojan Khanpara

Here is what I got from HDP experts:

1. Edit /var/lib/ambari-server/resources/common-services/HDFS/x.x.x.x.x/configuration/hdfs-site.xml

2. Modify the XML for commenting the <property-type>GROUP</property-type> tag. Like this:

<!-- <property-type>GROUP</property-type> -->
<description>The name of the group of super-users.</description>
<on-ambari-upgrade add="true"/>

3. Restart Ambari
ambari-server restart


That worked, thanks! Now I can see the option on the ambari UI.

Super Collaborator

I am assuming the above change wouldn't survive future Ambari upgrade.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.