Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hst server not comming up

Solved Go to solution
Highlighted

hst server not comming up

Contributor

2018-06-28 09:45:44,144 WARN [main] AbstractLifeCycle:204 - FAILED SelectChannelConnector@0.0.0.0:9000: java.net.BindException: Address already in use

java.net.BindException: Address already in use

1 ACCEPTED SOLUTION

Accepted Solutions

Re: hst server not comming up

Super Mentor

@kanna k

2018-06-28 09:45:44,144 WARN [main] AbstractLifeCycle:204 - FAILED SelectChannelConnector@0.0.0.0:9000: java.net.BindException: Address already in use


2018-06-28 09:45:44,148 ERROR [main] SupportToolServer:624 - Failed to run the SmartSense Tool Server
     java.net.BindException: Address already in use

On the host where you see the above error please check if there is any other process occupied that port some how?

If yet then kill that process and then try starting the HST server again.

Find Which process is using that port 9000

# netstat -tnlpa | grep 9000

The above command will show the PID which is using the port 9000 please check what that process is and then kill it if needed.

# ps -ef | grep $PID_FROM_ABOVE_COMMAND

# kill -9  $PID_FROM_ABOVE_COMMAND

.

Alternate approach: Or try changing the SmartSense port
Ambari UI --> SmartSense --> Configs --> Operations --> Web Ui Port (default is 9000)

But better to find the process which is using the port 9000 and then stop it to ensure that SmartSense can use that port.

9 REPLIES 9

Re: hst server not comming up

Super Mentor

@kanna k

2018-06-28 09:45:44,144 WARN [main] AbstractLifeCycle:204 - FAILED SelectChannelConnector@0.0.0.0:9000: java.net.BindException: Address already in use


2018-06-28 09:45:44,148 ERROR [main] SupportToolServer:624 - Failed to run the SmartSense Tool Server
     java.net.BindException: Address already in use

On the host where you see the above error please check if there is any other process occupied that port some how?

If yet then kill that process and then try starting the HST server again.

Find Which process is using that port 9000

# netstat -tnlpa | grep 9000

The above command will show the PID which is using the port 9000 please check what that process is and then kill it if needed.

# ps -ef | grep $PID_FROM_ABOVE_COMMAND

# kill -9  $PID_FROM_ABOVE_COMMAND

.

Alternate approach: Or try changing the SmartSense port
Ambari UI --> SmartSense --> Configs --> Operations --> Web Ui Port (default is 9000)

But better to find the process which is using the port 9000 and then stop it to ensure that SmartSense can use that port.

Re: hst server not comming up

Contributor

ps -ef | grep 9000

output:

~]$ ps -ef | grep 9000

myad+ 79718 76644 0 11:16 pts/0 00:00:00 grep --color=auto 9000

root 85623 1 0 Jun27 ? 00:00:03 ./portainer -p :9000 --data /home/myadmin/portainer_data

Re: hst server not comming up

Super Mentor
@kanna k

Please check if that process "portainer" is using port 9000?

# netstat -tnlpa | grep 85623

If yes then please try to run that process on a different port to avoid port conflict.

Re: hst server not comming up

Contributor

ps -ef | grep 9000

output:

~]$ ps -ef | grep 9000

myad+ 79718 76644 0 11:16 pts/0 00:00:00 grep --color=auto 9000

root 85623 1 0 Jun27 ? 00:00:03 ./portainer -p :9000 --data /home/myadmin/portainer_data

Re: hst server not comming up

Contributor

sudo netstat -tnlpa | grep 85623

tcp6 0 0 :::9000 :::* LISTEN 85623/./portainer

Re: hst server not comming up

Super Mentor

@kanna k

It indicates that your custom application "./portainer" is already consuming the Port 9000 hence HST server can not listen to that port and that the reason HST server is not coming up.

You have two options).

1). Either make the "./portainer" application to listen to some other port ... Or to kill it (Or refer to:

http://portainer.readthedocs.io/en/stable/deployment.html )

# kill -9 85623

2). Change the HST server port to something else than 9000

Ambari UI --> SmartSense --> Configs --> Operations --> Web Ui Port (default is 9000)

You need to choose between these two options.

Re: hst server not comming up

Contributor

please tell me how to run portainer in another port....

Re: hst server not comming up

Super Mentor

@kanna k

Please try this (it might or might not work as "portainer" is not a HDP product) So you will have to refer to it's documentation

# ./portainer -p :9100 --data /home/myadmin/portainer_data

.

Re: hst server not comming up

Contributor

It might be possible that HST-Server process might be started by another user. Can you please check the content of /var/run/hst/hst-server.pid for process PID to kill that process? After killing that process, you can restart HST. We recommend starting and stopping of HST server through ambari.