Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

impala catalog server JVM

avatar
Contributor

Hi.

I have a problem with outOfMemory error on impala catalog server.

Data in tables about 30TB and about 175k partitiions.

I set Java Heap Size of Catalog Server in Bytes=30gb, but still have out_of_memory error in start.

How can i calculate how much memory needs for catalog server? And is it have any limit to set ?

1 ACCEPTED SOLUTION

avatar

Slide 17 here has some rules of thumb - https://blog.cloudera.com/latest-impala-cookbook/

 

Can you mention what version you're running and whether you have any other non-standard configs set, e.g. load_catalog_in_background. We made some improvements in this area and have added some options in more recent versions.

 

View solution in original post

1 REPLY 1

avatar

Slide 17 here has some rules of thumb - https://blog.cloudera.com/latest-impala-cookbook/

 

Can you mention what version you're running and whether you have any other non-standard configs set, e.g. load_catalog_in_background. We made some improvements in this area and have added some options in more recent versions.