Support Questions
Find answers, ask questions, and share your expertise

impala shell connection

Contributor

Hello Team,

 

can you please help me with the connection to impala?

 

[root@rb-hadoop-02 admin]# impala-shell -i <HUE_IP>:27000 --user=hive
Starting Impala Shell without Kerberos authentication
Opened TCP connection to 10.10.104.106:27000
Socket error 32: [Errno 32] Broken pipe
***********************************************************************************
Welcome to the Impala shell.
(Impala Shell v3.4.0-SNAPSHOT (134517e) built on Sat Dec 12 11:15:02 UTC 2020)

Press TAB twice to see a list of available commands.
***********************************************************************************
[Not connected] > show dbs;
Connection lost, reconnecting...
Opened TCP connection to 10.10.104.106:27000
Socket error 32: [Errno 32] Broken pipe
Query: show dbs
Not connected (use CONNECT to establish a connection)
[Not connected] >

 

Thanks,

 

Roshan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: impala shell connection

Expert Contributor

Ok, so now it's a "connection refused error". Can you try without --ssl option, since you said Impala is not enabled with TLS/SSL. 

 

Are you able to ping the IP of your impalad server from the host where you are running impala-shell?

View solution in original post

6 REPLIES 6

Re: impala shell connection

Expert Contributor

Would be helpful to know which version of CDH or CDP you are using. 

Re: impala shell connection

Contributor

Hi,

 

thanks for the update.

 

Please find below details:

impalad version 3.4.0-SNAPSHOT RELEASE (build 134517e42b7b6085e758195465f956f431e0e575) Built on Sat Dec 12 11:15:02 UTC 2020
Version: Cloudera Enterprise 7.1.3 (#4999720 built by jenkins on 20200805-1701 git: fa596184790377f07ba80e9cd4da8b875237939c)

Java VM Name: OpenJDK 64-Bit Server VM

Java Version: 11.0.10

 

 

Thanks,

 

Roshan

Re: impala shell connection

Expert Contributor

Hello Roshan,


THe official documentation for using impala-shell to connect to impala is available here for your version of CDP:
https://docs.cloudera.com/cdp-private-cloud-base/7.1.3/impala-manage/topics/impala-shell-connecting....

 

Note that the default port to connect to impalad is 21000 (not 27000). Please check which port you are using in your deployment (can be done by running 

netstat -tulpn | grep impalad

on the host that's running impalad).

 

Another thing to check if SSL is enabled on in Impala on your cluster, you'll need to use --ssl option when connecting via impala-shell.


Regards,
Alex

Re: impala shell connection

Contributor

Hello Alex,

 

I have checked the port.

 

netstat -tulpn | grep impalad
tcp 0 0 <IP>:27000 0.0.0.0:* LISTEN 23290/impalad
tcp 0 0 0.0.0.0:25000 0.0.0.0:* LISTEN 23290/impalad
tcp6 0 0 :::22000 :::* LISTEN 23290/impalad
tcp6 0 0 :::23000 :::* LISTEN 23290/impalad

 

the port is 23290
I checked on Cloudera whether there is SSL for impala. Only Ranger configured.

 

[root@rb-hadoop-02 admin]# impala-shell -i <IP>:23290 --user=hive --ssl
Starting Impala Shell without Kerberos authentication
SSL is enabled. Impala server certificates will NOT be verified (set --ca_cert to change)
No handlers could be found for logger "thrift.transport.TSSLSocket"
Error connecting: TTransportException, Could not connect to <IP>:23290: [Errno 111] Connection refused
***********************************************************************************
Welcome to the Impala shell.
(Impala Shell v3.4.0-SNAPSHOT (134517e) built on Sat Dec 12 11:15:02 UTC 2020)

After running a query, type SUMMARY to see a summary of where time was spent.
***********************************************************************************
[Not connected] > exit;

 

Regards,

 

Roshan

Re: impala shell connection

Expert Contributor

Ok, so now it's a "connection refused error". Can you try without --ssl option, since you said Impala is not enabled with TLS/SSL. 

 

Are you able to ping the IP of your impalad server from the host where you are running impala-shell?

View solution in original post

Re: impala shell connection

Community Manager

@roshanbi, have you resolved your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. 

cjervis_0-1624451551299.png


Cy Jervis, Manager, Community Program

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum