Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

installing confluent on HDP 2.4

Explorer

how to install Confluent for Kafka Streams on HDP 2.4 can anyone provide me anyhelp on it @Benjamin Leonhardi

1 ACCEPTED SOLUTION

@Naresh Ar

HDP started shipping Kafka from 0.8.1 (HDP-2.2) and HDP-2.4 we shipped kafka 0.9.0.1 . Kafka Streams became GA in apache kafka 0.10.0 release and it will be part of upcoming HDP-2.5 release. You don't need any other kafka streams packages you can access them from here

http://repo.hortonworks.com/content/groups/public/org/apache/kafka/kafka-streams/ . As you can these are 0.9.0.1 release artifacts I advise you to wait for HDP-2.5 release which will contain most stable streams binaries.

View solution in original post

3 REPLIES 3

@Naresh Ar

HDP started shipping Kafka from 0.8.1 (HDP-2.2) and HDP-2.4 we shipped kafka 0.9.0.1 . Kafka Streams became GA in apache kafka 0.10.0 release and it will be part of upcoming HDP-2.5 release. You don't need any other kafka streams packages you can access them from here

http://repo.hortonworks.com/content/groups/public/org/apache/kafka/kafka-streams/ . As you can these are 0.9.0.1 release artifacts I advise you to wait for HDP-2.5 release which will contain most stable streams binaries.

Explorer

Actually i thought of implementing the below link on HDP so wanted to give a try

http://www.confluent.io/blog/how-to-build-a-scalable-etl-pipeline-with-kafka-connect

if we can make it out without using that could you explain the procedure @Sriharsha Chintalapani

Explorer

that's kafka connect, not kafka streams.. think you can get away with HDP 2.4 for that.