Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

java.lang.reflect.InvocationTargetException: : For custom Processor

Highlighted

java.lang.reflect.InvocationTargetException: : For custom Processor

New Contributor

I have created a Custom processor to use AWS Encryption SDK as a separate processor in NiFi version 1.7.1

I have implemented Abstract class with required Properties and createClient functions and processor main class with getSupportedPropertyDescriptors, onTrigger funtions.

But when I am trying to run the processor it gives below error:-


2018-08-15 23:15:39,732 ERROR [Timer-Driven Process Thread-5] o.a.n.p.a.encryption.EncryptorProcessor EncryptorProcessor[id=3eaf70a8-0165-1000-a4d1-6cfa42125382] Failed to properly initialize Processor. If still scheduled to run, NiFi will attempt to initialize and run the Processor again after the 'Administrative Yield Duration' has elapsed. Failure is due to java.lang.reflect.InvocationTargetException: java.lang.reflect.InvocationTargetException
java.lang.reflect.InvocationTargetException: null
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.nifi.util.ReflectionUtils.invokeMethodsWithAnnotations(ReflectionUtils.java:142)
at org.apache.nifi.util.ReflectionUtils.invokeMethodsWithAnnotations(ReflectionUtils.java:130)
at org.apache.nifi.util.ReflectionUtils.invokeMethodsWithAnnotations(ReflectionUtils.java:75)
at org.apache.nifi.util.ReflectionUtils.invokeMethodsWithAnnotation(ReflectionUtils.java:52)
at org.apache.nifi.controller.StandardProcessorNode.lambda$initiateStart$4(StandardProcessorNode.java:1499)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException: null
at org.apache.nifi.processors.aws.AbstractAWSProcessor.createConfiguration(AbstractAWSProcessor.java:221)
at org.apache.nifi.processors.aws.AbstractAWSProcessor.onScheduled(AbstractAWSProcessor.java:268)
at org.apache.nifi.processors.aws.AbstractAWSCredentialsProviderProcessor.onScheduled(AbstractAWSCredentialsProviderProcessor.java:65)
... 15 common frames omitted

2 REPLIES 2

Re: java.lang.reflect.InvocationTargetException: : For custom Processor

Explorer

I am also getting the same error

Re: java.lang.reflect.InvocationTargetException: : For custom Processor

New Contributor

I am developing a AWS Translate processor (which I hope to contribute back) but I am getting the same error. It is a relatively simple subclass of AbstractAWSCredentialsProviderProcessor. Looks like I'll be digging deeper but in the meantime I'm curious if anyone has made progress on debugging this?

Don't have an account?
Coming from Hortonworks? Activate your account here