Support Questions
Find answers, ask questions, and share your expertise

jdk1.8.0_311 compatibility

Explorer

My cluster is Ambari 2.7.5.0, HDP 3.1.5, all nodes RHEL 7.9.

 

When I look at the Cloudera Support Matrix and drill down to Oracle JDK 8, it specifies a minimum level of 1.8.0_77.  1.8.0_311 is out now, and I'd like to update my cluster to use that.

 

Is there a maximum level of Oracle JDK 8 I should use?  Are there Ambari/HDP issues with the latest JDK? 

 

Thanks for your consideration,

Mike

1 ACCEPTED SOLUTION

Accepted Solutions

Cloudera Employee

Hortonworks HDP 2.6.x and 3.x platforms support both Oracle JDK 8 and Open JDK 8 versions.Not validated, but supported as per doc

You can use the latest version but make sure you refer: https://my.cloudera.com/knowledge/Cloudera-Customer-Advisory-Servers-with-Kerberos-enabled-stop?id=2...

View solution in original post

2 REPLIES 2

Cloudera Employee

Hortonworks HDP 2.6.x and 3.x platforms support both Oracle JDK 8 and Open JDK 8 versions.Not validated, but supported as per doc

You can use the latest version but make sure you refer: https://my.cloudera.com/knowledge/Cloudera-Customer-Advisory-Servers-with-Kerberos-enabled-stop?id=2...

View solution in original post

Community Manager

@MikeB, Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: