Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

kafka metadata request


Hi there, I am just executing some KafkaTestCases on console. Zookeeper and Kafka brokers are started(I am seeing this in Ambari). There are 3 Zookeepers and 2 Kafka-Brokers are running.

I ran "bin/ --broker-list EdgeNodeAddress:xxxx --topic test21"

Note: EdgeNodeAddress is the console where i am issuing the producer console command and

I ran " bin/ --zookeeper zookeeperaddress:2181 --topic test21 --from-beginning" As soon as i ran the script, It keeps on generating message like

{,xxxxxxxx2.xxxxxx:7903,,, security.protocol=PLAINTEXT} This message is keeps on generating until i stop it myself. It goes on like "while loop without meeting condition" I troubleshooted zookeeper to check if i could see the broker list(ls /brokers/ids) and it shows the broker ids [0,1] I am not sure what is the issue.

Please share your knowledge on this ASAP. Thanks in advance.


In older versions of Kafka there was a bug described as the last bullet here: Open /usr/hdp/current/kafka-broker/bin/ and check do you have any lines exporting KAFKA_CLIENT_KERBEROS_PARAMS. If so, comment it out, and retry.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.