Support Questions
Find answers, ask questions, and share your expertise

kileld application not showing up in history server




I kiiled Yarn mapreduce application manually, after 50% mappers finished, I can see the mappers in Resource Manager UI while the job is in porgress, but after I killed application, I can not see the tasks window any more "Tracking URL: History"  not progressing to next window.


Same time this application not showing up in history server.


Using Cloudera enterprise 5.14.0


How can I diagnose issue, I ddin't see any exception in logs?


Also how can get rid of following message:


2019-05-03 04:58:32,835 INFO org.apache.hadoop.yarn.server.webproxy.WebAppProxyServlet: dr.who is accessing unchecked http://XXXm:44182/ws/v1/mapreduce/jobs/job_1551283647797_40054 which is the app master GUI of application_1551283647797_40054 owned by spothineni



Have you tried to get the logs from command line?

For secured cluster, run as "yarn" superuser:

yarn logs -applicationId {application_id} -appOwner {username}

For unsecured cluster, run as "root" superuser:

sudo -u yarn yarn logs -applicationId {application_id}

Will you get the result? Without seeing errors, it would be hard to tell why you don't see next page when clicking "History" button on that page, it can be caused by lots of factors.



Thanks for the reply.


I already tried yarn cli, its giving only the AM container log, seems it couldn't aggregate the other containers.



when a job is killed from Hue, job State: KILLED, FinalStatus: KILLED, should it complete the log aggregation for killed application?



Cloudera Employee



Is the issue happens for only one particular job? 





Any "manually" killed application not showing up in the history server. In resource manager I am not able to browse the tasks. We care using Cloudera 5.14.X


Any application killed by yarn does show up in  history server and able to browse tasks in resource manager.

; ;