Support Questions
Find answers, ask questions, and share your expertise

log_feeder module error

I upgraded smart sense from 1.4 to 1.5 on Ambari 2.4, hdp 2.5 but when i try to start the hst server from ambari ui, it thriws error below.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.5/services/SMARTSENSE/package/scripts/hst_server.py", line 10, in <module>
    from hst_script import HSTScript
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.5/services/SMARTSENSE/package/scripts/hst_script.py", line 14, in <module>
    from resource_management.libraries.functions.generate_logfeeder_input_config import generate_logfeeder_input_config 

ImportError: No module named generate_logfeeder_input_config

3 REPLIES 3

Contributor

Hi Tapas,

The module "generate_logfeeder_input_config" available in ambari 2.7 and above. SmartSense 1.5 requires Ambari 2.7 or above to work.

Please upgrade ambari to 2.7 or above.

Thanks,

Cabir

that explains why the HDP stack version was set to 3.0 in file.

I moved forward by commenting the logfeeder module import as i don't have logsearch service added in Ambari UI.

And my hst_server is up now. Are you saying this is a wrong way and I must use Ambari 2.7? hope my HDP 2.5 still stands valid

Contributor

Good to hear that you made it work. Yes, SmartSense 1.5 is supposed to work with Ambari 2.7 and above only. You can use older version of SmartSense which is compatible with your version of Ambari.

; ;