Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

mapreduce.job.running.map.limit has no effect

Highlighted

mapreduce.job.running.map.limit has no effect

New Contributor

I want to fix a limit for the number of running mapper per mapreduce job, I set the following parameter in my mapred-site.xml file

<name>mapreduce.job.running.map.limit</name>

<value>25000</value>

But it seems that this parameter has no effect. I found a job which takes 44543 mappers and in the configuration file i found the right parameter with the rigth value (25000).

Is there another parameter to activate this limit?

2 REPLIES 2

Re: mapreduce.job.running.map.limit has no effect

New Contributor

Thanks for your answer

I suppose this parameter is only for hive request?

Re: mapreduce.job.running.map.limit has no effect

Mentor

@Marie-Christine GONTIER

No of mappers depends on input split size it cannot be manually configured. Input split is a logical representation of data and block is a physical representation of data. An input split indicates the start and end point of data in a block.

There is one mapper per input split. so the number of mappers is not completely dependent on the number blocks. Depending upon the configured size, the number of splits varies. There might be one split per block, one split per two blocks or maybe two splits per block and so on.

HTH

Don't have an account?
Coming from Hortonworks? Activate your account here