Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

nameNode HA not working

Solved Go to solution
Highlighted

nameNode HA not working

Master Collaborator

I am using ambari to enable the namenode HA but its not detecting the checkpoint and not advancing the screen . please see below

11482-safemode.jpg

11483-screenshot.jpg

1 ACCEPTED SOLUTION

Accepted Solutions

Re: nameNode HA not working

Super Guru

@Sami Ahmad

Please save ambari-server and ambari-agent logs on the journal node machines for further reference.

One h@cky approach could be -

1. Copy the link from browser's address bar where enable Namenode HA wizard is stuck.

2. Open new tab in the same browser.

3. Paste the copied link.

4. increase the step number manually, i.e. if step4 is the last value in the copied url then make it as step5

5. press enter and move on!

Please don't forget to create a Hortonworks Support ticket if you have a support subscription, it will help us to identify a BUG and fix it to avoid further occurrences of this issue.

Hope this helps!

-Kuldeep

View solution in original post

3 REPLIES 3
Highlighted

Re: nameNode HA not working

Expert Contributor
@Sami Ahmad

ambari-web uses below pointed code to determine enabling of next button:

https://github.com/apache/ambari/blob/release-2.4.0/ambari-web/app/controllers/main/admin/highAvaila...

Following API call will help to debug further the reason behind this issue:

http://c6401.ambari.apache.org:8080/api/v1/clusters/c1/hosts/{NAMENODE_HOSTNAME}/host_components/NAM...

Value of Safemode and JournalTransactionInfo should not be empty.

value of LastAppliedOrWrittenTxId - value of MostRecentCheckpointTxId should be less than or equal to 1

Re: nameNode HA not working

Super Guru

@Sami Ahmad

Please save ambari-server and ambari-agent logs on the journal node machines for further reference.

One h@cky approach could be -

1. Copy the link from browser's address bar where enable Namenode HA wizard is stuck.

2. Open new tab in the same browser.

3. Paste the copied link.

4. increase the step number manually, i.e. if step4 is the last value in the copied url then make it as step5

5. press enter and move on!

Please don't forget to create a Hortonworks Support ticket if you have a support subscription, it will help us to identify a BUG and fix it to avoid further occurrences of this issue.

Hope this helps!

-Kuldeep

View solution in original post

Highlighted

Re: nameNode HA not working

Master Collaborator

awesome approach . .the work around worked.

thanks a lot

Don't have an account?
Coming from Hortonworks? Activate your account here