Support Questions
Find answers, ask questions, and share your expertise

need help on AWS/EC2 to start ambari by internal IP, not working

Contributor

this HDP/ambari install is without internet access on AWS/EC2.

Finally, I downloaded ambari repository, HDP and HDP_UTIL tarball files untar them, also, download ambari.repo file and replace to .etc/yum.repo.d. and setup and start ambari server.

I used this URL --- http://ip-172-31-62-67.ec2.internal:8080/, it seemed not workin

1. my /etc/hosts listed all internal IP for each node, since this is without internet access, so no public IP

2. error msg:

Host Not Found

DNS error (the host name of the page you are looking for does not exist) or Server did not accept the connection. Please check that the host name has been spelled correctly.

any suggestion?

thank you very much.

1 ACCEPTED SOLUTION

Accepted Solutions

7 REPLIES 7

Contributor

306-neeraj.pngyou are right, I need use public IP. so I had this URL

http://ec2-54-xx-xx-xx.compute-1.amazonaws.com:8080/

however, I still get this error, pls see attached image.

please help.

@Robin Dong You have to add 8080 port in your network security settings.

See this http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/authorizing-access-to-an-instance.html

Contributor

I think we are close to resolve this problem. tell me how to add this port to my network security settings.

AWS/EC2 have security group settings, I dont see the setting for port number. however, I will look into it.

thank you for this valuable info.

Robin

  • Go to the Security Group settings in the left hand navigation
  • Find the Security Group that your instance is apart of
  • Click on Inbound Rules
  • Use the drop down and add HTTP (port 8080)
  • Click Apply

Contributor

I have deployed cluster on Amazon EC2. I have followed this steps for Ranger as I want to add rule for Ranger in inbound rule. I have added inbound rule TYPE as Custom TCP and SOURCE as 6080. And now I want to open Ranger UI by using http://ec2-xx-xxx-xx-xxx.compute-1.amazonaws.com:6080. I still couldn't able to resolve my problem.

Contributor

Thanks Mr. Wonderful. yes, I can start ambari install after add HTTP role in security group configures. the default port for HTTP is 80, but 8080 still working. that is good.

thank you very much.

Robin