Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

nifi invokehttp not working for my api call without any error

New Contributor

Dear Team,

My api is not retrieving any data using invokehttp. Im able to get expected json data from cli but not from Nifi processor. 


https://resource-manager-serer:8090/ws/v1/cluster/apps?states=RUNNING -k --negotiate -u :


I have https and Kerberos. 





1. If you could share the complete InvokeHTTP Processor configuration and the cli command you executed that worked, that would be helpful in providing some guidance.
2. Was the cli executed from one of the NiFi servers?
3. Have you tried putting the InvokeHHTP processor class in DEBUG in the NiFi logback.xml to see if it provides anymore detail?

Thank you,

Community Manager

@Haden Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. If you are still experiencing the issue, can you provide the information @MattWho has requested?


Vidya Sargur,
Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.