Support Questions
Find answers, ask questions, and share your expertise

okta saml integration for EFM getting 403

New Contributor

Hi,

I have not been able to set up Okta SAML integration with EFM. The EFM server crashes soon after starting up.

1. created admin users in the UI

2. Followed steps to create a SAML integration with Okta and EFM in the Okta UI getting a metadata.xml file

3. uploaded that metadata.xml file to the conf directory of efm.

4. updated the efm.properties file to use the metadata.xml and the user attribute field

Attached are a few screenshots.

Thanks,

minh

users created in EFM.png
log error output.png
Screen Shot 2022-02-03 at 2.31.56 PM.png
3 REPLIES 3

Master Collaborator

Hi, Minh,

 

How and where from did you generate the metadata.xml file?

 

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Master Collaborator

Without having more information, it seems to me that the content of your metadata file is not correct. It seems to be a SAML Assertion, rather than a SAML Metadata document.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Community Manager

@lyminh Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. If you are still experiencing the issue, can you provide the information @araujo  has requested? Thanks!


Regards,

Diana Torres,
Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.