Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

oozie job fails without any errors

Solved Go to solution

oozie job fails without any errors

Expert Contributor

I am executing an oozie job and get an error in oozie job/action description windows but nothing in the launcher logs

Logs from oozie launcher:

Log Type: stderr

Log Upload Time: Wed May 11 15:48:00 +0530 2016

Log Length: 1721

May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory register
INFO: Registering org.apache.hadoop.mapreduce.v2.app.webapp.JAXBContextResolver as a provider class
May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory register
INFO: Registering org.apache.hadoop.yarn.webapp.GenericExceptionHandler as a provider class
May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory register
INFO: Registering org.apache.hadoop.mapreduce.v2.app.webapp.AMWebServices as a root resource class
May 11, 2016 3:47:44 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.9 09/02/2011 11:17 AM'
May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory getComponentProvider
INFO: Binding org.apache.hadoop.mapreduce.v2.app.webapp.JAXBContextResolver to GuiceManagedComponentProvider with the scope "Singleton"
May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory getComponentProvider
INFO: Binding org.apache.hadoop.yarn.webapp.GenericExceptionHandler to GuiceManagedComponentProvider with the scope "Singleton"
May 11, 2016 3:47:44 PM com.sun.jersey.guice.spi.container.GuiceComponentProviderFactory getComponentProvider
INFO: Binding org.apache.hadoop.mapreduce.v2.app.webapp.AMWebServices to GuiceManagedComponentProvider with the scope "PerRequest"
log4j:WARN No appenders could be found for logger (org.apache.hadoop.mapreduce.v2.app.MRAppMaster).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

Log Type: stdout

Log Upload Time: Wed May 11 15:48:00 +0530 2016

Log Length: 0

but the windows shows oozie job failed with this error in oozie window:

Main class [org.apache.oozie.action.hadoop.SqoopMain], exit code [1]

I am basically executing a sqoop job from oozie workflow. how do I check if there was an error while executing sqoop job?There is nothing in /log/sqoop either.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: oozie job fails without any errors

You need to look at the output of the actual sqoop job running in yarn. Hue/Oozie UI/Resource manager/ or yarn logs -applicationId <> allow you to read them.

6 REPLIES 6

Re: oozie job fails without any errors

You need to look at the output of the actual sqoop job running in yarn. Hue/Oozie UI/Resource manager/ or yarn logs -applicationId <> allow you to read them.

Re: oozie job fails without any errors

Expert Contributor

I am not running Hue. should try yarn logs . Thanks

Re: oozie job fails without any errors

Expert Contributor

@Benjamin Leonhardi: It shows no error in yarn logs either:INFO resourcemanager.RMAppManager$ApplicationSummary: appId=application_1462448478130_0139,name=oozie:launcher:T\=sqoop:W\=once-a-day:A\=fabricinventoryimport:ID\=0000074-160506102107434-oozie-oozi-W,user=oozie,queue=default,state=FINISHED,trackingUrl=http://warehouse.swtched.com:8088/proxy/application_1462448478130_0139/,appMasterHost=warehouse.swtched.com,startTime=1462961859126,finishTime=1462961873135,finalStatus=SUCCEEDED,memorySeconds=349055,vcoreSeconds=27,preemptedAMContainers=0,preemptedNonAMContainers=0,preemptedResources=<memory:0\, vCores:0>,applicationType=MAPREDUCE

Re: oozie job fails without any errors

There are two applications

-the oozie launcher ( one AM one map task look in both ) here you would find any errors kicking off the sqoop job. Most likely in the map task that runs the sqoop command.

- the actual sqoop application, this one will have one am and x mappers. You could find errors here as well.

And there are the three different outputs you will know the right one when you see it. The log you send seems to be the appmaster and is meaningless.

Re: oozie job fails without any errors

New Contributor

@simran kaur, I just met the same problem, did you solve this ? If yes , could you give me some hints, many many thanks !

Re: oozie job fails without any errors

New Contributor

so - how was it solved??

Don't have an account?
Coming from Hortonworks? Activate your account here