Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

oozie shell action doesnt send email


I am running a shell script through oozie. A piece of my shell script has below code. I receive an email when I run this shell script through unix Command line but when I run this shell script through oozie Job it will succeed but I dont get any mail. How can I resolve this? Or is there any alternative way I can get email with attachment once string matches in unix filesystem?

if [ "$Var" = "Error" ] then echo "Data error" | mail -v -s "Data Error" -a error.csv -S smtp=smtp://mail-gateway -S" exit


Rising Star

Do you receive email when you run the mail command manually on different worker nodes in your cluster (remember shell action will run on a randomly assigned worker node)?


It works, When I manually run mail from worker and master nodes. When I runt the shell script from oozie. it doesnot work.

Cloudera Employee

I would suggest to use a Decision node and an Email action instead of sending the mail from a shell script.

If you prefer the shell, make sure you set every environment variable that's needed for the mail command to work.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.