Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

oozie spark action table not found

New Contributor

I am trying to set up a spark action workflow within apache oozie though I'm getting the following error when select * from db.table is called within my spark code in a hive context:

org.apache.spark.sql.AnalysisException: Table not found: `db`.`table`; line 1 pos 34

This spark job works with spark-submit so I can't seem to nail down the issue. I've added hive-site.xml to various locations recommended in previous questions such as the workspace lib directory and the workspace directory and added it to the job.xml setting though I still get the same issue.

I'm running in deploy mode cluster and master yarn.

I've tried many combinations and not sure what else to do.

Where am I going wrong?

1 REPLY 1

New Contributor

Hello @Abdul Haseeb Hussain, I am experiencing the same exact problem and I am completely stuck.

Did you find a solution to the issue?

Thx a lot!

Simone