Support Questions
Find answers, ask questions, and share your expertise

oozie sqoop error "sqoop-site.xml (permission denied)"

Solved Go to solution
Highlighted

oozie sqoop error "sqoop-site.xml (permission denied)"

New Contributor

Hi,

 

I have recently encountered an error whilst trying to execute a simple sqoop action through oozie. When running I get the error "sqoop-site.xml (permission denied)".

 

I have searched the internet for the same error but have found nothing.

 

The sqoop command works when run independently from oozie.

 

I am running the job with all the permissions I should need for the oozie job. 

 

Here is my code (with generic names)

 

Property file

 

nameNode=hdfs://server.domain.local:8020
jobTracker=server.domain.local:8032
applicationDir=${nameNode}/user/username/sqoop/
oozie.wf.application.path=${applicationDir}
oozie.use.system.libpath=true

workflow.xml file

 

-<workflow-app name="sqoop-workflow" xmlns="uri:oozie:workflow:0.4">

-<parameters>
-<property>
<name>jobTracker</name>
</property>
-<property>
<name>nameNode</name>
</property>
-<property>
<name>applicationDir</name>
</property>
</parameters>

<start to="sqoop-action"/>

-<action name="sqoop-action">
 -<sqoop xmlns="uri:oozie:sqoop-action:0.2">
 <job-tracker>${jobTracker}</job-tracker>
 <name-node>${nameNode}</name-node>
 <command>import --m 1 --connect "jdbc:sqlserver://ServerName:1433;database=Database;username=Username;password=Password" --table MyTable--target-dir /user/hive/warehouse/sqoop/MyTable-- --schema dbo</command>
 </sqoop>
 <ok to="success"/>
 <error to="fail"/>
</action>

-<kill name="fail">
<message>The Identity Map-Reduce job failed!</message>
</kill>
<end name="success"/>

</workflow-app>

Possible causes I can think of is the sqoop element is running with different permissions or running on an instance without sqoop installed.

 

I need help in both diagnosing the problem and advise on how to overcome it.

 

Thanks

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: oozie sqoop error "sqoop-site.xml (permission denied)"

New Contributor
Just Incase anyone wanted to know, to fix this had to reinstall the oozie share lib directory

View solution in original post

3 REPLIES 3
Highlighted

Re: oozie sqoop error "sqoop-site.xml (permission denied)"

New Contributor

Update to this:

 

I've seen that the sqoop-site.xml (permission denied) failure is actually complaining that it cant find the file with a FileNotFoundException

 

Does anyone know why this would be the case?

Highlighted

Re: oozie sqoop error "sqoop-site.xml (permission denied)"

New Contributor
Just Incase anyone wanted to know, to fix this had to reinstall the oozie share lib directory

View solution in original post

Re: oozie sqoop error "sqoop-site.xml (permission denied)"

Community Manager

Thank you for sharing how you fixed it dom99. Feel free to mark your last comment as the solution so others in a similar situation can find it easier. 


Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum
Don't have an account?