Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

opensearch , nifi

New Contributor

I want to connect opensearch with nifi but it is showing error while running processor of sending data. it shows failure of requests . i have also tried different version of nifi with opensearch but still same error . How can i solve it? screenshot of error




Community Manager

@soc88, Welcome to our community! To help you get the best possible answer, I have tagged in our NiFi experts @cotopaul @steven-matison who may be able to assist you further.

Please feel free to provide any additional information or details about your query, and we hope that you will find a satisfactory solution to your question.


Vidya Sargur,
Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

Super Collaborator

@soc88 Some suggestions so community can better help you:

  1. Show screen shots of processor's configuration tab.  We need to see the properties and how you have setup the processor.
  2. For processors with errors (red boxes), you can click the box to see full error. We need to see the errors to suggest solutions.
  3. Look in nifi-app.log for these errors if you need more verbose errors than shown in the UI.  You can also set the processor log level to see more in the UI.  For example, set it to DEBUG and test again.


I would suspect your error could be the configuration of the processor, but would more suspect opensearch permissions on receiving end and less about the version of NIFI.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.