Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

org.apache.hive.hcatalog.data.JsonSerDe not found

Highlighted

org.apache.hive.hcatalog.data.JsonSerDe not found

Contributor

Trying to get serde working with zeppelin and/or the spark shell. Running the following in either

val links = sqlContext.sql("SELECT * FROM test_links LIMIT 10")

links.show()

Produces an error

ERROR hive.log: error in initSerDe: java.lang.ClassNotFoundException Class org.apache.hive.hcatalog.data.JsonSerDe not found java.lang.ClassNotFoundException: Class org.apache.hive.hcatalog.data.JsonSerDe not found

Tried added this to /etc/spark/conf/hive-site.xml

<property>

<name>hive.aux.jars.path</name> <value>file:///usr/hdp/2.5.3.0-37/hive2/lib/hive-hcatalog-core.jar</value>

</property>

But am still getting the error.

2 REPLIES 2

Re: org.apache.hive.hcatalog.data.JsonSerDe not found

New Contributor

This has been solved previously: 1. HIVE_AUX_JARS_PATH in the hive-env.sh or set on your shell (not hive cli) will override the one set by "hive.aux.jars.path" in hive-site.xml. However calling "hive -hiveconf hive.aux.jars.path=..." will override HIVE_AUX_JARS_PATH setting in hive-env.sh. Using "hive --auxpath ..." will append file to any settings you may have in HIVE_AUX_JARS_PATH.2. Since we ship the Apache Hive binaries so hive.reloadable.aux.jars.path should be supported on any hive shipped since HDP 2.2.0.3. "hdfs:///" is supported on add jar, doubt if hive.aux.jars.path supports it.4. Wildcards are not supported in both hive.aux.jars.path and add jar. See previous post by Deepesh (looks like a HWX worker) at https://community.hortonworks.com/questions/2390/methods-to-add-jars-to-hive.html

Re: org.apache.hive.hcatalog.data.JsonSerDe not found

Contributor

Thanks, adding the jar to HIVE_AUX_JARS_PATH in hive-env.sh got SerDe working in zeppelin

Don't have an account?
Coming from Hortonworks? Activate your account here