Support Questions
Find answers, ask questions, and share your expertise

org.apache.thrift.transport.TTransportException: Invalid status -128 ,CDH 6.2.1 , no kerb

New Contributor

Please help on the below :

 

[HiveServer2-Handler-Pool: Thread-13365]: Error occurred during processing of message. java.lang.RuntimeException: org.apache.thrift.transport.TTransportException: Invalid status -128 at org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:219) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.server.TThreadPoolServer$WorkerProcess.run(TThreadPoolServer.java:269) [hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_181] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_181] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181] Caused by: org.apache.thrift.transport.TTransportException: Invalid status -128 at org.apache.thrift.transport.TSaslTransport.sendAndThrowMessage(TSaslTransport.java:232) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.transport.TSaslTransport.receiveSaslMessage(TSaslTransport.java:184) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.transport.TSaslServerTransport.handleSaslStartMessage(TSaslServerTransport.java:125) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.transport.TSaslTransport.open(TSaslTransport.java:271) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.transport.TSaslServerTransport.open(TSaslServerTransport.java:41) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] at org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:216) ~[hive-exec-2.1.1-cdh6.2.1.jar:2.1.1-cdh6.2.1] ... 4 more

4 REPLIES 4

@shrimaha Not very much clear from the logs but you might be hitting something similar reported here : https://community.cloudera.com/t5/Support-Questions/Getting-error-in-hiverserver2-log/td-p/201305

 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

have configured postgres as external db .. there were issues in connecting to hive ..So have already replaced postgres jdbc jars with latest ones available .Please help to resolve the same .

Contributor

@shrimaha It looks like you're using wrong jdbc connection string to connect to Hive, could you please check your connection string details once.

 

https://community.cloudera.com/t5/Community-Articles/Working-with-Beeline/ta-p/247606

 

https://docs.cloudera.com/HDPDocuments/HDP2/HDP-2.6.5/bk_data-access/content/beeline-vs-hive-cli.htm...

 

Thanks,

Prakash

New Contributor

The Issue was due postgresql jdbc jar whcih comes with Cdh was not latest .

 

I had manually downloaded the latest jars and replaced the old ones and then the issue was resolved .

Thanks for the help !!!

; ;