Support Questions
Find answers, ask questions, and share your expertise

pig scripts disappear after saving

Solved Go to solution
Highlighted

pig scripts disappear after saving

Contributor

create a pig script.

save it

confirmation message comes back to confirm that it has been saved

go to something else, like "tez view"

go back to pig

it says that there are no scripts. my work has vanished.

in one case, I was able to run the script, go over to tez to see what had happened, and when returned to pig it was gone (even after saving)

tried this a couple of times and the same thing happened. scripts disappeared each time.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: pig scripts disappear after saving

Guru

@michael klybor

Take a look at supported browsers with ambari here. Try sticking to them even if on sandbox since there are some known issues on other browsers.

View solution in original post

5 REPLIES 5
Highlighted

Re: pig scripts disappear after saving

Expert Contributor

Is this happening on SandBox?? Can you provide little more details on the version of Sandbox, browser, etc.. ??

Also, please check and ensure that your user (ambari user) has write permission in the directory where you are trying to save your script to (you can always change the hdfs path to the desired directory while creating the new pig script)

Highlighted

Re: pig scripts disappear after saving

Contributor

yes it is the sandbox, out of the box, no config changes made. just downloaded it the other day, so it is the most recent version.

browser IE 11

I've noticed a couple of other weird things happening, and I have a suspicion of browser compatibility issues with IE 11. will try this with chrome.

trying to save into the default directory, just following the tutorial scripts. so whatever directories, permissions etc. that are set in the sandbox VM are what are being used. will check on permissions.

Re: pig scripts disappear after saving

Contributor

@hduraiswamy

this seems to be an IE 11 compatibility issue. It works fine with Chrome.

Chrome shows all of the pig scripts that were created. IE shows some of them. it seems to show only those that were created during a prior session. I created two new ones just now. one with chrome, one with IE. Chrome shows all of the scripts (created previously, new from chrome, new from IE), IE doesn't show the ones that were just created (either with chrome or IE).

Highlighted

Re: pig scripts disappear after saving

Expert Contributor

@michael klybor - thanks for confirming.

Highlighted

Re: pig scripts disappear after saving

Guru

@michael klybor

Take a look at supported browsers with ambari here. Try sticking to them even if on sandbox since there are some known issues on other browsers.

View solution in original post