Support Questions

Find answers, ask questions, and share your expertise

problems with login

Explorer

Hallo. After installing the Hortonworks Sandbox HDP 2.6.5. en load the virtual machine on my laptop, I could not login conform instructions in my learnbook ($ ssh root@127.0.0.1 -p2222 en password should be hadoop).

It wasn't succesffully. What to do now ?

Thanks in advance !

Frank

1 ACCEPTED SOLUTION

Explorer

yes..! The ambari screen.

What is the login ? (Sorry;-). )70da332f-8724-4988-9c4a-3ca43816e869.jpeg

View solution in original post

18 REPLIES 18

Rising Star

May I know which steps you have followed and at what step you are stuck so I can help you

Explorer

hallo Pankaj,

Thanks.

My learnbook is the quick-start guide of Hadoop2.

The steps I followed was install the box and after that to load the virtual machine, exactly like the instructions in my book.

At the end I started this VM 2.6.5. and there came a console window.

With Fn+Alt+F5 there came 'login' and this should be:

($ ssh root@127.0.0.1 -p2222 / password hadoop).

.Either not succesfull, also when I tried 'admin', so this is the point where it stopped for me now.

Rising Star

Hello Frank

Please refer https://hortonworks.com/tutorial/learning-the-ropes-of-the-hortonworks-sandbox/

Determine the IP address of of your virtual machine and then try ssh

ssh root@127.0.0.1 -p2222 what is the output of this command is there any password prompt I hope you are running this command from shell within the VM ? what is the output of docker ps command from shell of the VM 2.6.5

Explorer

Hi Pankaj,

I determined the IP adres of the place I am working now and suppose this is also the IP adress of my virtual machine ?

I tried to logon exactly with this: 'ssh root@xxx.xxx.xx.xx -p2222'

After this there appeared a prompt to fill in the password: 'hadoop'.

Atter this it struggled and restarted again with the login prompt.

(Yes, indeed from shell in the black scream VM done)

Don't understand your last question about the output of docker ps command from shell of the VM2.6.5.

Thanks ! 😉

Explorer

still not working,

And how does it work with the IP adresses of Docker, virtual box and VMware ?

It should be very nice when somebody is able to give my the right advice.

Explorer

hi Pankaj, (or somebody else)

Is there a possibility you will support me to solve the problem with inlog in the Virtual machine ?

Rising Star

Hi Frank

Please give me the link from which you have downloaded the sandbox so I will download that sandbox and will create same environment on my mac to provide you exact steps to setup it properly

Explorer

downloaded from the hortonworks site.

Should be here.

https://hortonworks.com/downloads/#data-platform

And after this the sandbox.

Rising Star

I have downloaded the same sandbox and I was seeing this info on the virtualbox screen

83496-screen-shot-2018-08-01-at-54224-pm.png

Then I accessed SSH address in the browser and I was able to login to SSH with password hadoop

83498-screen-shot-2018-08-01-at-54258-pm.png

Explorer

Hoi Pankaj,

Either... SSH adress in the browser (chrome or explorer) doesn't work.

http://localhost:4200/ > 'This site is not available'. 'Connection refused'.

Explorer

b1339e17-0491-4c25-9fe4-03d8cfb49541.jpegHallo Pankaj,

Now I have the same result like you, see printscreen below, what to do now finally ?

Rising Star

great now you can use ambari url in the browser and can login to ambari gui to manage your installed services

ambari url should be http://localhost:8080

if this does not work then confirm me the URL or IP you have used to login to the shell so I can give you ambari url accordingly

Explorer

yes..! The ambari screen.

What is the login ? (Sorry;-). )70da332f-8724-4988-9c4a-3ca43816e869.jpeg

Rising Star

you can use username raj_ops password raj_ops

Username maria_dev Password maria_dev

if you want to use admin user then first from sandbox shell reset the ambari admin password using command

ambari-admin-password-reset

then set the admin password

and restart ambari server using command

ambari-server restart

Explorer

Using raj_ops was succesfully

Using maria_dev was succesfully

How great it looks !!

But can you explain to use / change the admi inlog or my personal inlog in simple other words ?

(Hope this will be my last question, after this it should be possible to follow my learnbook for the next steps)

Rising Star

First login to sandbox shell

run the command

ambari-admin-password-reset

This will ask you the new admin password once you set the password then restart amabari-server using command

ambari-server restart

Now you should able to access ambari using admin password

Note: Please accept the answer if everything is sorted

Explorer

Of course I will do accept the answer.

Not sure at the moment. Finishing suppose tom morning.

Explorer

Thanks for support Pankaj,

All succesfull now.

Wish you a happy day and hopefully nice weekend !

Kind regards,

Frank

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.