Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

"Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

"Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

Below is the message i get when trying to open the Cloudera Manager web page (its 5.4.2 Quickstart VM for Vmware)

 

Attempting to connect to Cloudera Manager...

By default, the Cloudera QuickStart VM run Cloudera's Distribution including Apache Hadoop (CDH) under Linux's service and configuration management. If you wish to migrate to Cloudera Manager, you must run one of the following commands.

To use Cloudera Express (free), run Launch Cloudera Express on the Desktop. This requires at least 8 GB of RAM and at least 2 virtual CPUs.

To begin a 60-day trial of Cloudera Enterprise with advanced management features, run Launch Cloudera Enterprise (trial) on the Desktop. This requires at least 10 GB of RAM and at least 2 virtual CPUs.

Be aware that after rebooting, it may take several minutes before Cloudera Manager has started all of the services it manages and is ready to accept connects from clients.'

 

 

What do i do?

9 REPLIES 9

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

Perhaps the issue is that you must start the cloudera manager by clicking on the Desktop Icon "Launch Cloudera Express" icon.  

 

It will tell you that you I think need at least 2 cores dedicated to the cloud, plus 8 gig of memory.

 

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

Hope you would have solved this issue by now.

 

right click in CM express in desktop and chage the sudo from --pause to --force and open ,this is one time process.

After it is completed ,you can connect cm from mozilla.

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

I am also having the same problem. Getting the same message ' Connecting to Cloudera Manager" and it hangs forever. Tried launching Cloudera Express from the desktop but it is already running and nothing happend.  All the services etc. are also running. Do I need to have Cloudera Enterprise to bring up Clouder Manager?

 

Appreciate if you could let me know how to bring up Cloudera Manager.

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

Here is my experience and how I solved the issue.

 

After I installed mysql both oozie and cloudera manager stopped working.

 

After I looked at the log  /var/log/cloudera-scm-server, I created user in mysql and granted permission. Both started working. 

 

Here is the script 

 

CREATE USER 'oozie'@'localhost' IDENTIFIED BY 'cloudera';
GRANT ALL PRIVILEGES ON *.* TO 'oozie'@'localhost' WITH GRANT OPTION;

 

CREATE USER 'cm'@'localhost' IDENTIFIED BY 'cloudera';
GRANT ALL PRIVILEGES ON *.* TO 'cm'@'localhost' WITH GRANT OPTION;

 

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

Thanks

The same issue i was facing.This post helped me in resloving the issue.

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

it worked for me too.

 

did following:

[cloudera@quickstart ~]$ mysql -uroot -pcloudera

Welcome to the MySQL monitor.  Commands end with ; or \g.

Your MySQL connection id is 234

Server version: 5.1.73 Source distribution

 

Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.

 

Oracle is a registered trademark of Oracle Corporation and/or its

affiliates. Other names may be trademarks of their respective

owners.

 

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

 

mysql> CREATE USER 'oozie'@'localhost' IDENTIFIED BY 'cloudera';

Query OK, 0 rows affected (0.00 sec)

 

mysql> GRANT ALL PRIVILEGES ON *.* TO 'oozie'@'localhost' WITH GRANT OPTION;

Query OK, 0 rows affected (0.00 sec)

 

mysql> CREATE USER 'cm'@'localhost' IDENTIFIED BY 'cloudera';

Query OK, 0 rows affected (0.00 sec)

 

mysql> GRANT ALL PRIVILEGES ON *.* TO 'cm'@'localhost' WITH GRANT OPTION;

Query OK, 0 rows affected (0.00 sec)

 

 

and then closed and reopened the vm. It started working afterwards.

Thanks for solution!.

Highlighted

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

Community Manager

@Diksha_v06  I'm happy to see you resolved your issue. Please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. 

 

 

 

 Screen Shot 2018-12-17 at 12.14.06 PM.png

 

 



Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

I'm facing the same issue and tried your workaround, still no luck. Later i found out that i'm not able to connect to even google from mozilla. I checked some other things and found out that there is no network connections. Problem is that i haven't change any configuration and my VPN got disconnected. So, can you please help on this

Re: "Connecting to Cloudera Manager" - hangs forever -5.4.2 Quickstart VM for Vmware

New Contributor

I'm facing the same issue while connecting to the cloudera manager from mozilla. i tried your workaround but it's not connecting. Later when i dig more i found out that i ain't able to access the google.com as well. So, i checked my network connection on cloudera desktop. it was disconnected. Problem is i have never changed any congifuration regarding the network and i don't know how it got disconnected. 

 

can u please help to get it connected it again. I guess this will resolve my issue.