Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

"Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

"Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

New Contributor

I am trying to launch Ambari dashboard but I see a message to disable popup blocker(which is already done). And I am taken to a page where it says "Site can't be reached" I can however see the tutorial page loading beside.

I am on windows 10

VirtualBox : Version 5.2.4 r119785 (Qt5.6.2)

HDP_2.5_virtualbox

5 REPLIES 5

Re: "Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

Super Mentor

@Sumisha Surendran

Are you using HDF/HDP sandbox?

Are you able to connect to the ambari server Host (IP) and Port using terminal? Please check the following command output from your local machine where you are trying to open the Browser

# nc  -v  127.0.0.1  8080
(OR)
# telnet  127.0.0.1  8080

.

On the ambari server host please check:

1. If the port 8080 is actually opened?

# netstat -tnlpa | grep 8080

2. Please check the ambari-server.log for any error/strange behaviour. Please share if you notice any error.

# less /var/log/ambari-server/ambari-server.log

.

Re: "Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

Super Mentor

@Sumisha Surendran

Another way to quickly isolate if there is any Browser issue (OR) Network Issue (OR) Port Reachability issue (OR) ambari server issue. Please try to make the following Ambari API call from the host where you are running the Browser to see if you are able to connect to ambari server and able to make API calls?

# curl -u admin:admin -i -H 'X-Requested-By: ambari' -X GET http://127.0.0.1:8080/api/v1/services/AMBARI/components/AMBARI_SERVER


If above call also fails to connect then it means either ambari server did not start properly (or) there is some Hostname/Port accessibility issue.

.

Re: "Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

New Contributor

Hi Jay,

i tried the above command and got below output.

[root@sandbox ~]# curl -u admin:admin -i -H 'X-Requested-By: ambari' -X GET http://127.0.0.1:8888/api/v1/services/AMBARI/components/AMBARI_SERVER HTTP/1.1 500 INTERNAL SERVER ERROR Server: gunicorn/19.1.1 Date: Sun, 27 Jan 2019 07:06:29 GMT Connection: close Transfer-Encoding: chunked Content-Type: text/html; charset=utf-8

same issue i am having, not able to launch Dashboard. Can you please help me what else i need to check.

Thanks in advance.

Re: "Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

New Contributor

I am not able to connect to ambari server using terminal.

Re: "Please disable popup blocker" message is displayed while trying to launch Ambari (127.0.0.1:8080)

New Contributor

Hello,

I have the same problem. When I try to launch the dashboard. I obtain the following message for the uri

http://localhost:8080/#/main/dashboard/metrics

Access-Control-Allow-Origin: * 

Error : no method specified in uri /

I test the commands below but I don't find error in the running command and logs.